What happened to the site?



Looks the same in incognito/normal, tried clearing the cache, etc. I also don’t have any Preview window while creating a post, which is also quite strange. Everything is in a weird place and it feels like quite a few elements just aren’t there. Anyone else seeing this?

Looks fine to me.

1 Like

Very cool- time to restart my computer, I guess :grin:

1 Like

I’ve experienced some glitches as well.

1 Like

this must be the beta version.

1 Like

A bit off top, but do you guys also get constatnt crashes from the site, this morning?

I’ve made no changes over the past weeks. More detailed reports about issues and how to reproduce them would be helpful. Thanks!

With no plugins or extensions (I’ve disabled everything), on the latest version of Chrome (108.0.5359.126), on Windows 10, this is what I see on the site:

I’m getting a ton of JavaScript errors on page load:

The FetchEvent for "<URL>" resulted in a network error response: the promise was rejected.
The FetchEvent for "<URL>" resulted in a network error response: the promise was rejected.
The FetchEvent for "<URL>" resulted in a network error response: the promise was rejected.
The FetchEvent for "<URL>" resulted in a network error response: the promise was rejected.
The FetchEvent for "<URL>" resulted in a network error response: the promise was rejected.
NetworkFirst.mjs:167 Uncaught (in promise) no-response: no-response :: [{"url":"https://blenderartists.org/assets/plugins/discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js"}]
    at a.makeRequest (https://blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
NetworkFirst.mjs:167 Uncaught (in promise) no-response: no-response :: [{"url":"https://blenderartists.org/assets/plugins/discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js"}]
    at a.makeRequest (https://blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
NetworkFirst.mjs:167 Uncaught (in promise) no-response: no-response :: [{"url":"https://blenderartists.org/assets/plugins/discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js"}]
    at a.makeRequest (https://blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
NetworkFirst.mjs:167 Uncaught (in promise) no-response: no-response :: [{"url":"https://blenderartists.org/assets/plugins/discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js"}]
    at a.makeRequest (https://blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
NetworkFirst.mjs:167 Uncaught (in promise) no-response: no-response :: [{"url":"https://blenderartists.org/assets/plugins/discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js"}]
    at a.makeRequest (https://blenderartists.org/javascripts/workbox/workbox-strategies.prod.js:1:2145)
VM510 content.js:57 The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
(anonymous) @ VM510 content.js:57
content-scripts.js:1 INS: content-ads.js loaded:  https://blenderartists.org/
content-scripts.js:1 TSS: content-tss.js loaded:  https://blenderartists.org/
content-scripts.js:1 INS: content-blocked-items.js loaded:  https://blenderartists.org/
content-scripts.js:1 CONTENT_SHELL: Page allowed. Skipping shell injection blocks
content-scripts.js:1 GET TAB ID RESPONSE:  Object
discourse-adplugin-1086ea180d40e5cb86d0dbf09194e8c74d5b5ad49fd42a70588c8bf9afb5ecb4.js:1          Failed to load resource: net::ERR_FAILED
content-scripts.js:1 TSS: excluded result:  Object
content-scripts.js:1 TSS: Excluding content tss (trigger: send-mesage)
6fc1704……74ba187637c01a.js:2 Uncaught SyntaxError: Cannot use import statement outside a module
plugin-api.js:19 [THEME 63 'discourse-social-links-clickable'] To prevent errors in tests, add a `pluginId` key to your `modifyClass` call. This will ensure the modification is only applied once.
fe @ plugin-api.js:19
deprecated.js:27 [THEME 55 'discourse-homepage-feature-component'] Deprecation notice: use injected siteSettings instead of Discourse.SiteSettings (deprecated since Discourse 2.8) (removal in Discourse 2.9)
e.default @ deprecated.js:27
DevTools failed to load source map: Could not load content for https://blenderartists.org/assets/service-worker-82df40abc519449957ece197ca5af4c30bea872013d650ef4471b98114dcc2ce.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE
DevTools failed to load source map: Could not load content for chrome-extension://bmnlcjabgnpnenekpadlanbbkooimhnj/browser-polyfill.js.map: System error: net::ERR_BLOCKED_BY_CLIENT
[Violation] Added non-passive event listener to a scroll-blocking 'mousewheel' event. Consider marking event handler as 'passive' to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952
​ [Violation] Added non-passive event listener to a scroll-blocking 'touchmove' event. Consider marking event handler as 'passive' to make the page more responsive. See https://www.chromestatus.com/feature/5745543795965952

The main issues I’m seeing are these: I can’t resize the post-creation box, the post-creation box doesn’t have the preview window, each reply on a topic has a disabled horizontal scrollbar, the side scrollbar doesn’t work:

And weirdly, the Sidebar button is on the wrong side of the screen:

The site dashboard says that a critical update is available, it’s possible that may be the problem.

On Mac, things look better, although I’m still getting a bunch of critical JavaScript errors:

6fc1704……74ba187637c01a.js:2 Uncaught SyntaxError: Cannot use import statement outside a module
theme-errors-handler.js:100 [THEME 34 'Portfolio Settings'] TypeError: Cannot read properties of null (reading 'username')
    at theme-field-113-common-html-script-1.js:19:38
    at e.withPluginApi (plugin-api.js:1909:1)
    at Object.initialize (theme-field-113-common-html-script-1.js:15:22)
    at o.initialize (app.js:41:1)
    at index.js:126:1
    at e.each (dag-map.js:192:1)
    at e.walk (dag-map.js:121:1)
    at e.each (dag-map.js:66:1)
    at e.topsort (dag-map.js:72:1)
    at e._runInitializer (index.js:138:1)
    at e.runInstanceInitializers (index.js:124:1)
    at e._bootSync (instance.js:101:1)
    at e.didBecomeReady (application.js:650:1)
    at p.invoke (queue.ts:201:14)
    at p.flush (queue.ts:98:13)
    at h.flush (deferred-action-queues.ts:75:19)
    at B._end (index.ts:616:32)
    at B._boundAutorunEnd (index.ts:257:12)
y @ theme-errors-handler.js:100
plugin-api.js:19 [THEME 63 'discourse-social-links-clickable'] To prevent errors in tests, add a `pluginId` key to your `modifyClass` call. This will ensure the modification is only applied once.
fe @ plugin-api.js:19
deprecated.js:27 [THEME 55 'discourse-homepage-feature-component'] Deprecation notice: use injected siteSettings instead of Discourse.SiteSettings (deprecated since Discourse 2.8) (removal in Discourse 2.9)
e.default @ deprecated.js:27
head_tag_1.js:16 after event started 3
head_tag_1.js:20 page rebaked
head_tag_3.js:6 hide adsense top v2
The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
The Content Security Policy directive 'upgrade-insecure-requests' is ignored when delivered in a report-only policy.
adsbygoogle.js:198 [Report Only] Refused to evaluate a string as JavaScript because 'unsafe-eval' is not an allowed source of script in the following Content Security Policy directive: "script-src https://blenderartists.org/logs/ https://blenderartists.org/sidekiq/ https://blenderartists.org/mini-profiler-resources/ https://blenderartists.org/assets/ https://blenderartists.org/brotli_asset/ https://blenderartists.org/extra-locales/ https://blenderartists.org/highlight-js/ https://blenderartists.org/javascripts/ https://blenderartists.org/plugins/ https://blenderartists.org/theme-javascripts/ https://blenderartists.org/svg-sprite/ 'report-sample' 'sha256-HZxBMVZe6P3MvHDZlFai9cUmLH+qwX6BNT3qTwNPATg=' 'unsafe-inline' https: https://pagead2.googlesyndication.com/".

yp @ adsbygoogle.js:198
show_ads_impl_fy2021.js?bust=31071640:388 hhli: initializeGfpCookieStateForShowAds called
show_ads_impl_fy2021.js?bust=31071640:388 hhli: initializeGfpCookieStateForShowAds called

This leads me to believe it’s a Windows-specific problem, as that’s the only difference between my two tests here.

I know you’re on a bit of a break so there’s no rush to look into this :slight_smile:

Couldn’t reproduce it on Windows 11 with the newest Chrome.

1 Like

Firefox on Linux also works fine.

1 Like

Hmm ok so it’s definitely just me, but I’m still seeing problems even in Incognito mode. There might be some kind of local cache file that’s loading incorrectly, I’ll delete all my temporary files and see if that helps. Guess it’s not a site issue at least, so no need to worry about it

Also fine on Vivaldi (5.5…) and debian linux… and even and older Opera (Version:67.0.3575.137 …the newest is 94.0.46…)…

1 Like

Have you tried with an account that has the usual user rights only (non crew)?

1 Like

That’s a really good idea- I just tried that, and it worked! So that’s even stranger :thinking: I’m 100% confident this is some kind of local cache problem now, so I’m going to close this thread. Thanks for the help, everyone :slight_smile:

1 Like