What is causing these rendering artifacts?

Attached is a render I did with Blender 2.49 and Yafaray 0.1.1, and there are a bunch of little black pixel squares that I can’t figure out. They are 2x2, 3x2, 3x3, or some combination of that, with some overlapping others. It’s almost like the rendering engine didn’t draw in those blocks for some reason. Has anyone ever encountered this before, and more importantly, do you know how to correct it? I can provide any Blender settings that would help, and I’ve attached the YafaRay settings.

(P.S. Yes I know that I forgot the A in YafaRay.)

Attachments



As I recall, the black dots are usually the result of a bug in Yafaray’s handling of glossy Blender materials. It was supposed to be fixed in Yafaray 0.1.2. Do you have glossy reflections activated in any materials?

I am using some glossy materials in YafaRay. I am not using any gloss maps to my knowledge. That sounds like it could be the issue since the bad pixel blocks are in places where the text is reflected. What is the solution? Do I change to another material type, or is there an adjustment I can make to the glossy materials in YafaRay?

try turning the ray depth down. 8 levels of ray depth is way more than you need for that render. Hopefully that will fix it.

Ok, I will try some test renders at lower depths to see if that removes the bad blocks. I used 8 levels so that the glass objects would have multiple reflection iterations of the surrounding objects. The “infinite mirror” effect. I’ll post the results back here.

Can anyone tell me how to render a region of the camera (like what I cropped above) instead of the full view?

yes, you can render a partial by clicking the ‘border’ button. then you have to define the rendering area, but i forget the hot key. i think it’s something like ctrl B ( and draw box ).
(edit) just looked it up, it is shift-B from camera view.

I re-rendered the sphere section at a Raydepth of 7, 6, and 5 with no change to the bad pixel blocks.

I tried changing all of the settings in the glossy materials one at a time. I discovered that turning the Anisotropic button off (light blue) in the glossy or coated_glossy materials will remove the artifacts. There must be a bug in the Anisotropy calculations that causes null rendering blocks.

Thanks for all the help folks!

If you are ok without anisotropy, then that’s great! Nice work.