What is it and how do I make it go away.

I was trying to do a nice little render for this character I was working on and I keep having these horrible little outline artifacts show up. Sort on texture face items does nothing to change it, clip alpha, and alpha still cause them to show up.

The only condition they are there in is if I place my character in the bucket shaped backdrop for rendering. The bucket is a cylinder with a slightly smoothed incline to the walls of the structure. The normals are facing inwards, there is a slight texture on it. On a blank backdrop it’s fine.

Anyone else ever had this problem or have any pointers? I set this example on just shadow to highlight them over the suspect parts of the mesh. It does the same thing only even more obvious with the texture rendered normally.

Attachments


probably a normals issue, or a co-located face. select all and try to face-normals-face outside. otherwise, you have to hunt them down one by one and solve them.

Normals all checked, all facing outwards like they should be. No co-located faces, no weird mesh abnormalities. It seems to happen between the body, cape, and bucket-shaped backdrop. Opaque object, alpha enabled object, opaque object.

Hi,

Do you have ZTrans enabled?

rawpigeon your handle is hilarious and you got it! I can replicate the problem now and for some reason it decides it doesn’t want to screw up if ALL the objects have ZTrans enabled, regardless if all the objects are even going to have any alpha changes. I guess if it’s not a reported bug already I’ll mention it to the blender crew. Thanks for the help!

Works fine now. Glad I know how to fix that now. Just so maybe this will keyword for anyone else frustrated with this in the future “obnoxious white outline, how to get rid of it”.

Attachments