What is that?

I was trying to do SHIFT+CTRL+T with one hand but I did obviously something else and that box appeared around my mesh. :confused:


I gathered that it’s related to “Texture Space”, I can resize it with SHIFT+ALT+T but I don’t have a clue about its purpose. I dug in every menu and panel accessible in Edit Mode but I haven’t found anything unusual… :spin:

What is it? And most importantly, how do I get rid of it?

In the “Object” panel, disable “Texture Space” that you probably enabled earlier.
http://i.imgur.com/pEQds.jpg

how do I get rid of it?

Properties window, under Object (cube icon) / Display, untick ‘Texture Space’

Facepalm Thanks!

Next job: Kill that shortcut that is definitively of no use to me… :evilgrin:

If you want to know how to use Texture Space see http://blendermama.com/generated-mapping-and-texture-space.html