What is the problem with the smoke here?

Why is the the smoke in viewpoint look so much better than the smoke in eevee?

And why is it white, and not dark gray?

You likely won’t get it 1-to-1 identical, as the rendering in viewport is done quite differently. But to get the result closer:

  • The volume scatter density needs to be higher.
  • I assume you have only scatter but not volume absorption. You need the latter also to get dark smoke.

When I play the animation, it looks like this, but when I pause it, most of the smoke disappears.

Also, how do I get rid of the bounds box wireframe?

Not sure why the smoke disappears on still rendering. Actually when playing anims in viewport in rendered mode chances are the render will be incomplete. When in doubt, assume that the still render is the one working correctly. I have little experience with Eevee, but I’m surprised that it shows more smoke in anim and not less. What about final renders? Do they look like stills in viewport? Can you tweak the shader so it looks good in stills, or is that somehow not working?

About the bounding box, when one defines the object to be a smoke domain, object->viewport display->display as will be automatically changed to ‘Wire’, Set it again to ‘Solid’ or ‘Textures’ and you won’t see the bounding box anymore (or to be exact: you will only see ti, if the object is selected).

Here is the .blend itself if you can figure out what’s wrong with it.


Ah, found it. The problem is the render settings for volumetrics. Setting the start/end distances too large will use too few samples for the relevant depth range. Here I tweaked it to match the distance of the smoke quite closely, and getting as a result thick and quite detailed smoke:

Forget about the anim in viewport. You will only see very incomplete sampling for the smoke. As the first few samples hit the smoke it appears thick at first an becomes thinner the nore faw-away samples are added (which come out empty).

Thank you!