What`s causing this ??


This bug constantly happens now and again while running in BGE.
The Rifle is parented to a empty, the empty is parented to my armature hand bone.
There is no collision on rifle, but it gets jumpy. How can i fix this problem.

Hi, is “slow parent” activated on an object? http://www.pasteall.org/blend/38966

No i checked that. It`s really bugging me lol, that was a bad pun.

If you give a .blend, I may find it… Otherwise - no!

It can happen if you parent a thing to another thing, that is parented with a bone of an armature. Is it the case?

I haven’t seen this effect since 2.38

This is just a guess, but it might worth to try:
In the World tab, try to increase Logic steps or or FPS, substeps or some of the other options.

I tried, but no luck.
It`s driving me crazy, i might have to upload my .blend it seems.

are you using IK or copy rot?

I have had this problem with IK before

also, is everything scaled to 1,1,1 ?

There’s an “Extra Object Update” checkbox under Relations Extras, maybe that would help (or maybe not). I’ve had this problem one time before on a very slow computer, to me it occurred while the framerate were very low.

You might want to upload the .blend-file to get this solved quicker.

Im uploading the .blend now and will send it too you guys, its driving me nuts.

Are you using IK or Copy rotation?

I have had this problem before

try switching the solver to Itasc in armature settings (near the bottom)

I tried that BPR, but it did nothing i sent you the file.

Did you check if you clicked accidentally “slow parenting” button? It seems it might be “slow parenting” feature enabled.

Yeah i looked on everything and there turned off. I will have to send you guys the file.

Ok send it. It’s probably something stupid and obvious, those kind of bugs are the hardest to find.

I tried it in 2.74.5 -> no bug

it seems to be a IK problem introduced after 2.74.5?

I would get 2.75 and see if it has the issue, then if it does, try 2.74.5

and then report your findings to the bug tracker.

2.76(first release) = Bug

also try one of the newest builds off buildbot?

Will do BPR. I will tell you if it worked going back a few blends.

Yup well done BPR.
Just tried it on 2.75 and what do you know, no problem. I`m reporting it now mate.