What's going on here? 1K and 4K versions of same texture shading differently

I’m a bit confused here - I mocked out a scene using a 1K version of a texture and it appears to UV map fine. However, when I then swap the textures out to the 4K version of the same texture, the shading appears all “sharp” (also the roughness etc is way altered).

What’s causing this? Re-UV unwrapping doesn’t do anything, and I’ve tried combinations of auto smooth normals/weighted normal modifiers etc. Why would the same texture work fine at 1K and not at 4K? I can’t see anything wrong with the actual texture either when opened in a graphics editor.

Any ideas how to fix the shading for the 4K?

This looks like a normals issue, how are your texture nodes plugged in?
Make sure that the normal and bump map image texture nodes are set to “non colour” (colour space), and that you are using the correct normal map space in your normal map node.

1 Like

Argh! It was indeed. When I updated the textures in the nodes, it must have reverted to sRGB for the normal maps. Changing it back to non-colour has fixed it.

Never even crossed my mind to check the that the node settings had changed. Thanks!