What's the best way... 3D view image map

Yes, I’m a noob. I have gone thru several tutorials for the basics and now I’m proceeding to the whole reason for learning Blender. I need to produce architectural renders for a project. I have 2D floorplans that I want to use to locate objects (walls, windows, doors, etc.) When I create a plane and texture it with the floorplan image I see it in the render but it does not show in the 3D view. I can also see it in the preview window. I need to either a) use the preview while adding/positioning objects, or b) display the texture while in edit mode. I have attempted to create a UV texture but this seems to be overkill and the methods I have found were too complex and didn’t work. I don’t have the skills yet to follow. Any suggestions?

This may help.

Cheers, and welcome to Blender! :slight_smile:


hmmm, yes, this will allow me to start. The challenge with a background begins when I need to display two floorplans at the same time. The workaround would be replacing the background with a new one and then moving the existing contents to the proper relative position. Also, I was hoping to be able to raise the floorplan in the z-axis so it blocks certain elements during placement of others.

If you absolutely need an actual 3-dimensional object, you can texture a plane (as you did before), enable the Shadeless and Texface options for the material, and switch to Textured View mode. There might be a more elegant solution, but this one should do the trick.

Also, a quick tip: When texturing your plane, hit Alt-V to make the plane match the image’s aspect ratio.


Sounds simple… I made all these settings and it still doesn’t show in 3D view.


Whoops. I think I skipped a step or two. Seems it only works if the plane has been UV mapped. Try this and see if it works any better…

Change one of your windows to the UV/Image Editor.
Tab into Edit mode, make sure the plane is selected, then hit U and choose Unwrap.
In the UV/Image Editor window, select your image from the drop-down menu.

That should work. Lemme know if it doesn’t.

Amazing! Yours is the first description of creating a UV map that was simple enough to follow and it actually works! thank you thank you thank you


You’re very welcome, and I’m glad I could help. :slight_smile:

I was trying to figure out how I missed those steps to begin with, and discovered that you can skip the UV mapping if you’re using the GLSL mode (which I am on my desktop, but not on my laptop). It’s a better viewport renderer in general, and might save you a minute or two mucking about in the future. The only real downside I’m aware of is that it doesn’t work all that well with lower-grade graphics chips, most notably Intel GPUs.


And now its even simpler. Thanks, that works well also. There is a slight delay after selecting the texture image and seeing it in the 3D view, I’m guessing that is what you are referring to as far as greater graphics requirements. I’m running a NVIDIA GeForce 8800M GTX, so its not a low-end card.