***Whats the best way to set up Optimize Blender to help prevent render crashes??***

I’m following a tutorial on Andrew Price’s Architecture Academy, and my scene is freezing up during my renders.
So in general I want to know all the different ways to optimize Blender. The PC I’m using is solely for 3D modeling, is there things I can do to my OS to allocate more memory,power, etc to Blender?? I want to be able to handle big complex scenes and to reduce freezing/crashing during renders. Are there additional programs I can use in conjection with Blender to assist with Renders? Any other honest advice is welcome to. :slight_smile:

Here is what I’m working with:

Blender Version- 2.70a (Just got 2.71)
OS- Windows 8
CPU- Intel Core i7 processor 4770
RAM- 12GB DDR3 Memory
HDD- 1TB HardDrive
Video- Nvidia GeForce GTX 760 1.5GB

What sort of crashes are you experiencing? blender crashing? CUDA crashing? Bluescreen Crashes?

I take it you render on the GPU?

The Achilles’ heel of GPU rendering and the number one reason for render crashes/freezes is running out of the graphics card’s sparse memory. The 2 GB of your GTX 760 (the 760 comes in 2 GB and 4 GB variants, not 1.5 GB, at least to my knowledge) are simply not enough for demanding scenes.

So, you can either render on the CPU instead and live with the (much…) longer render times or get a new graphics card with significantly more VRAM.

As far as I know the screen just goes grey, and then the little dialog box comes on and says “Blender is Not working” It eventually closes. I don’t think its a CUDA because I currently have it rendering off of the CPU, I also did try using the GPU, but unfortunately it freeze up at the same spot.

Okay, I may have to upgrade the VRAM on the graphics card, which one do you recommend?

If you don’t render on the GPU, that can’t be the reason for your crashes… So, no need to upgrade.

What is the memory consumption of that scene shortly before Blender crashes?


My memory is:2265.87m and Peak is:2265.87.

Something odd just happened I just literally upgraded from 2.70 to 2.71… and my render worked :/, I didn’t adjust any settings or anything, it still rendering but its about done, doesn’t seam like its going to freeze. What do you make of this? I’m perplexed :slight_smile:

Maybe it’s a bit far fetched, but is it possible that your Blender 2.70 was (by accident) a 32bit version and 2.71 is 64bit (as it should)?

Well I didn’t think of that, you may be on to something lol, I may have had a 2.70 (32bit) version.

There you have it, then.

As far as I understand, any 32bit process will be limited to 2 GB RAM on a 64bit OS unless “IMAGE_FILE_LARGE_ADDRESS_AWARE” is flagged, which I am uncertain about concerning Blender. So, your previous render attempts crashed as soon as the memory consumption hit the 2 GB mark (see the current peak of 2.2 GB).

Now, with 64bit Blender 2.71, that limit is no more.

That makes sense to me. Thanks again for your help :slight_smile:

oh solved, but maybe a good tip

if your making architectural movies, always render to images, not straight to mov / avi etc
in that case you can always retry a missing frame, in case your computer freezed for whatever reason (sometimes i hate windows update, causing unplanned reboots) or other things that happen outside blender that crash a computer power outage etc…

just out of curiosity, how do you end up with 12 gigs of RAM? I didn’t know they sold 6 gb sticks.

The LGA1366 motherboard was triple channel ram instead of dual channel… as in you installed it in lots of three

With an 8 and a 4? Or three 4’s?