Whats wrong with my cloth sim? Cloth are always "noisy" with self collision enabled [SOLVED]

Guys i noticed what every time i enable self collision on any cloth sim which i try became complitely unrealistic and “noisy”, like if we appy random noise to all selected vertices.
I check some tutorials and notice what other people didnt get same results.

As example:

My results would be imidiately look like this:

Considering the fact what guy on the video just put a cloth modifier and didnt touch any settings except the pin group and self collision, and my mesh have approx the same polycound i expect similar results, but as you can see my sim look complitely different.
Playing sim further didnt change anything, cloth will remain the same noisy mess.

Im on 2.92.0 maybe its some bug or something? Or i just missed some settings for cloth simulations?

Without a file to look at, this looks like what happens when the sim modifier is stacked after and not before certain other modifiers like solidify.

I realize what was off on my side: self collision distance which are 0.015 by default are too big.
I just change it to 0.005 in immidiately get nice results.

1 Like

Awesome! Glad you got it figured out. Welcome to the simulation side of Blender, your life for a bit will be lots of trial and error. :grin:

Great advice.

Simulations can be SO FRUSTRATING!

So many settings… so little time. :laughing:

1 Like