What's wrong with this?

Hi,

please take a look at the attached blend file.
I have the letters ‘b’ and ‘f’ position above my green ground plane.
The material of the letters consist of 40% glossy and 60% diffuse shader.
If I render this I get a reflection problem on the ‘neck’ of the letter ‘b’.
I marked this area with the red arrow and the number 2.
In this area the green floor is not reflected, this area is darker.
To start analysis I added a cube and placed it above the neck of the ‘b’, see red arrow with number 1.
There you can see this part is rendered correctly it reflects the green ground floor.


Then I moved the cube towards and ‘inside’ the neck of the cube and rendered again.
You can see at the same position of the neck the cube is rendered correctly.
So there must be a problem with the ‘b’.


I tested also with blender font instead of verdana, but same problem.
Then I converted the ‘b’ to a mesh, but still same problem.

What goes wrong here?

Thanks for any help!

Attachments

cycles_test.blend (1020 KB)

That’s strange, I’ll follow this thread to see what explanation you get about what is causing the problem.
I’ve seen two things seem to solve the problem. Add an Edge Split modifier to the “b” letter. Or convert “b” to mesh and select the problematic face, then separate selection with P.
Another observation. With “flat” shading also seems well.

Yes it’s the shading. If you turn on smooth shading (from the tool shelf, T) for the mesh piece you have there, it gets dark sides too. Also, shading changes when the geometry changes. You can probably see the shading change when you drag either offset or bevel values back and forth in text properties.
The reason edge split modifier or manually splitting (hotkey Y) mesh faces works is because it doesn’t matter if the shading is smooth or flat, the surface is flat since the edges are split in both cases.

You can clear the image by adding edge split modifier to both of the letters (fixing dark corners on the f too).
Area light is the only light rendered. Enable ‘multiple importance sample’ on it and with that you get less noise.

As mentioned above, just adding the edgesplit modifier to the text object without converting to mesh fixes your problems.
Possible reasons your mesh conversion did not simplify things: you did not remove doubles, did not recalculate normals. Additional unusual geometry problems in the tip of the F caused by using offset on your text, but offset is necessary because of the counter in the B. Unfortunately text to mesh results in sad faces ; ( if you’ll excuse the pun! Deleting all the faces and retopologizing the front face is necessary. I used the F2 addon from Bart Crouch which mostly involved holding down the F key and watching the addon do all the work : ) Then used the edgesplit as elsewhere advised.


Attachments

letterB.zip (344 KB)

Hi,

thanks to all, now I got deeper understanding to solve my problem!

Thanks!