When adding a new material index to an object...

Is there a way to stop blender from creating a new and useless material that i’m not going to use.

Start a fresh Blender session, clear the texture associated with the default cube’s material and delete the cube. If you want a default cube when you start Blender create a new cube. CTRL-U to save defaults.

No thats not really what i meant, this is for any mesh, it happens every time. I have a mesh, it may have already have a material on it, it may not but when i add a material blender invents a new material and its a copy of the last mater.

The last material might be called rust1, i add a new material index and suddenly that new index is called rust1.001

I dont want that, it means saving exiting and re-opening blender to get rid of an unwanted material, because for that new index i have probably got a material in mind and ready to apply before hand. Having a useless material kicking about cluttering up the menu effing annoys me because things can get confusing.

These attachment are before and after of what i mean.

All i want is to add a material index and for that index to be empty: with no material default or otherwise.


You have to go back to the materials tab and delete it. This only unlinks, however and a hollow “o” will appear next to that name. I don’t think there is a way around this…

:frowning: This is annoying. There must be a workaround somehow.

I don’t know, if you select the material name and then delete it followed by a save, it does not come back when you reopen.

Yes, unless the material being copied has a node setup or is beign used by another material in its nodes, then deleting a material can become a chore, it’d be better if there was a comprehensive solution to the problem.


I guess i am going to have to modify blender myself, this is such a simple problem, how hard could it be?

(i’ve never looked at the blender code before)

looks at the dev section on blender.org


Well, if a material is being used somewhere, it has to hang around.

And i should have the ability to get rid of it completely if i so want, but i can’t, not without having to close everything down and re-open it.

Ideally it shouldn’t have to be there in the first place, but i can’t prevent that either. :frowning:

Yes you can, in fact I just did it for fun. Get rid of it and save user preferences. Ctrl+Ukey


That’s great if my latest and greatest model is the default cube, but as soon as you add a new material index, blender invents a new material.

This is fine at first, but what happens later on when a project is maturing and i have many materials and i need no more?

I definately don’t want blender to complicate things by adding unneccissary materials for the heck of it.

Just because a new object needs a new material index, it doesn’t mean i’m going to need an entirely new material.

I know its only a small problem, which takes about 5-15 seconds to get around by deleting, saving, exiting and re-opening the file but do this enough times and it becomes frikin annoying.

By definition, “every visible object must be associated with some material.” For this reason, Blender will automatically create one.

If you subsequently associate the object with a different material, the “orphaned” material will no longer have any objects associated with it. (Its “user count” will be zero.) Because of this, it won’t be saved the next time the file is saved … and it won’t exist at all the next time the file is reloaded.

This scheme allows new objects to be “immediately usable, and immediately distinct,” without any further attention on your part. It ensures that all objects have at least one material associated with them at all times. I think it’s a reasonable implementation as-written.

Owwy, the face slap hurt! Just trying to help out!

but i can’t, not without having to close everything down and re-open it.

ctrl-s to save followed by ctrl-o to open and you won’t have to shut anything down. or ctrl-w / ctrl-o

Come on, folks, this one’s easy.

TheANIMAL, it is not possible to create an empty material index on your model.
However, it is possible to create a new index with an existing material. But you have to be in Edit Mode.

Select the vertices you want to have the new material.

Choose the desired material from the indicated pop-up in my attached image.

No need to even click Assign! This creates a new material index on your object without creating a new material. If you want there to be no material assigned to that index, hit F5, then click the X next to the material’s name.

@pixelmass: I could be wrong, but I always thought “facepalm” was the name of a smiley that exasperatedly smacks itself in the face. Hence… your face should be fine…?


I don’t understand your big concern with this? It is just the way Blender works.


Thanks, this is as close as i’ll come to a solution, and it should definately slow the frequency of annoyance.

Sorry pixelmass for the afront, i was smaking my forehead, not yours.

Thanks for the explination GryphonRider.