When i say knife don't work i don't care of those for whom it works !

… So stop saying it works for you it’s damn useless and pretty boring to me.

Hi all !

Ok. It’s a long tell tale. Since i started to use the new 2.5+ blender series i had problems with knife and
ALWAYS had people saying it all works fine to them. Those people obviously talk about things they don’t
know and didn’t experiment as i can just simply proove what i assert. This topic will be the main place
where i put in the future screenshots of ‘knife don’t work’ :slight_smile:

I wish i had time ( and therefore money ) to spend it to develop a real efficient tool that simply works. It’s
just a matter of small maths but the language for coding and the blender api complexity prevents me from
doing this. For just eating i have to spend time somewhere else than on this. Unfortunately.
Hopefully some people developped some addons that help a lot when intersecting faces. Unfortunately they’re
not as convenient as the knife tool would be if it works. Nevertheless i have to send them here a BIG thank
for their work !!!

so let’s start with knife awards: Knife on selected faces ( SHIFT-K ) Blender 2.66



Of course i have to mention that those screenshots are not my first deception on the knife tool :slight_smile:
EACH time i tried to use it, it didn’t cut properly things, and i had to find another way of doing what
i needed.
Ah also i’ve been told, after complaining about the knife, that the latest blender version knife works fine
NOW ( looooool ) Mostly as if each new release comes with a big advert saying in red “with new knife that works !”
So please don’t bug me with nightly builds including the last bandage on the knife code :wink:

regards to all and have a good knife ! :smiley:

Ah also, i forgot to mention that the knife bug is tightly dependant on 3D view space. When in front view, the cut i wanted to do in the previous post worked ! Note that this is not always the case, but the knife behaviour is never the same, depending on the 3D view space.
It is also the case for ‘where you cut the edge’. I noticed that depending on the position ( i can talk about pixels in view space ) you cut an edge, the cut works or doesn’t…

Is the problem in your screenshot that it hasn’t cut anything on the right selected face or something else, you don’t actually say ?
As far as I can see just from the top screenshot you haven’t created a new face on that side with the knife. Is that deliberate or it not detecting a cut ?

If you want to raise issues you need to clearly explain what the issue is. If it’s a reproduceable bug report it.

For modelling issues like this it would be more useful for you do a screencast rather than just screenshots

If you provide a .blend for others to try and it works for them, that means the problem is at your end. You are the source for information for developers in that case. You can compare what is different in your setup or what others do differently so that it works for them. So no, it’s not useless information.
Unless of course bug reports are useless too and you prefer whining, in which case I highly recommend you stop wasting our time with unproductive threads and

you have to make a face. you cant just make random cuts into your model and expect it to work. from your screen shot it looks like the knife is working fine.

unproductive ? i confess i’m ! as much as those saying knife works ! And as much as you’re saying i’m.

What i pretend here is just nothin but the truth. When i say it don’t work i’m particularily pissed off with those saying
(you are dumb !) it works. as a former coder in asm\C\C++ with 20 years of pain, i can affirm that a code that d’ont
work in all cases is assumed not to work at all. What if your car only runs in straight highways and stops then there
are turns ? Would you say: well… keep quiet and then move the car to the proper direction and run it again ?
don’t make me laugh !
The knife don’t work just because it hasn’ been properly tested at dev. That’s all and indeed not my fault.
Therefore i cannot accept ppl telling me shut up when others lie saying knife works properly !
Please be honest !

provide a .blend. Well i dont want to provide my blends here as they’re not CC files. And the point is that when i get
rid of all faces except the faces i want to knife-cut and then try the knife cut, the knife uses to work. Once again this
could simply be explained with the test mode of the knife: if it works for a tri or quad, it also works for complex thousands
of poly. This is wrong. there are many (easy ) ways to stress test such an algorythm, and i bet none of them have been
used.

Now that all this is said, i’m ready so send some blends ( in a private way ) to dev team for bug tracking. The point is that in some
cases after 20-30 tryouts, the cut can be achieved ( sorry i have no afternoons to loose for cutting a hole in a wall ). I mean
that ( as i previously said ) in function of the vewing angle and/or in function of the place ( in the middle of a tri ) you put your
cutting points, the cut is ok and correct or is not and messy… Therefore, imho it’s no use providing blends as the bug is by nature
not reproductible because of a random behaviour. This behaviour must be eliminated ( meaning part or whole rework of the algorythm )
to make blends submission and bug report usefull and efficient.

If someone in the dev team, instead of people giving me lessons because i’m whining, want to get in touch with me to constructfully
talk about this problem and mebe solve it ( i’m not that snooty tho ) i’d really be happy to contribute.

@richard: sorry i don’t have tools for screencasts and honestly i thought that the 2 pics in my 1st post were explicit enough for all to understand. In the 1st one the knife cut shape ( with one unexplained missing red line ) and at the bottom the result after ENTER. It’s obvious that in the 1st pic i want to cut the rightmost face. at least i think it is… isn’t it ? On the 2nd pic the result without any cut in this face… i confess i could have made and F-KEY to hide the cut part but i didn’t. My aim is not at saying rubbish on this subject. i promise that the screenshot is just after the ENTER key.

As a last word… lets be serious… i consider blender as an awesome tool ! In such an application, a knife tool is a mandatory thing, and the fact it works quite randomly though particularily frustrating and pissing off ( i confess patience is not my best quality :smiley: ) didn’t yet make me throw blender away for using another modeler… I put my sadeness in my pocket and go on using all other awesome things.
Nevertheless i think that one day or another, the knife question will have to be discussed and answered. Obviously and honestly. The earlier, the better.
And finally for answering the JA12 lesson-giver, sorry, i won’t follow your recommendation, and i won’t be quiet on this. Honestly i hope you thank me one day for this when you read me saying:“Oh men ! now the knife works !!! congratz to all” (and i bet this will happen it’s quite obvious ) . Mebe you won’t but it’s not important. What is important is that tool we all call blender :slight_smile:

regards to all.
and have nice blends !

EDIT: @small troll ( ahah love your name ! it would perfectly suit to me :smiley: )
nope look at the missing red line in the topmost pic. I guess it’s one of the reason the rightmost face is not cut… mebe yes mebe not, i dunno but the fact is that this face is not cut though i wanted it to be cut along the red line/dots.
Then from your POV the knife works fine… ok. because i cant cut any shape in may model and expect it to work… well ok :slight_smile: then if the knife is not intended to make cuts in model i’m wrong and present my apologies to all… hmmm just before this i’d like to be really sure the knife is not intended to make cut in faces… really… i thought it was: http://wiki.blender.org/index.php/Doc:2.6/Manual/Modeling/Meshes/Editing/Subdividing/Knife_Subdivide but mebe i’m wrong…

works in a similar scenario here. I tried to make cuts in the faces, starting with the one on the top left and the arrived at the area I extruded to look like your model’s faces. I used K for knife, clicked each point I wanted to have, and then clicked the last to close it and pressed enter, and I got closed faces each time. I have to ask if there is maybe a situation where a face is duplicated in place, and might interfere with your knife cut? I ask this because you indicate that it works well on simple objects, but not on complex cases, and just thought maybe there is something compounding the issue.

Attachments


That’s like telling your doctor that he has to diagnose you without examining you. Don’t want to share your precious private files? Fine. Create a new example file that demonstrates the problem and let us look at that. If you don’t want to give us the information we need, stop asking us for help.

This is the Blender Artists forum. If you have a bug report for the dev team, what are you doing here? Go make a bug report to the developers.

You’re telling people that there’s a problem, but no one else can replicate that problem. It only seems to happen to you, which is why people keep telling you that it works for them. If it’s only happening to you, it’s probably something you’re doing, otherwise it would happen to everyone. We are all using the same program, after all. But maybe it’s a real bug, in which case we need to be able to see it. If you don’t want to give us a file that demonstrates the problem, then you’re on your own. Don’t complain about other people being unhelpful if you’re not willing to give them the information they need in order to help you.

Yes you do. You have Blender. http://www.youtube.com/watch?v=ZhtrUP5qOLA

Then prepare one that is. Select faces, duplicate, P to make it a separate object and copy/paste or append that object to another .blend (copy/paste in blender 2.66).

That’s your choice of course. As is ours to read your thread and help.

thanks for you lesson wise horseman.

@Craig Jones: Thanks for you post Craig. You say you use K-KEY. i use SHIFT-K-KEY. mebe that could make a difference ?
I’ll have to try this out on my models. The thing is that this strange behaviour i have ( missing red lines on a knife cut shape ) happens on all my 3 machines… i can imagine my current PC is quite crappy, but all 3 of them… i have a doubt…

regards.

Who here thinks this quote should be added to my signature block? :smiley:

Also, Craig might have spotted something important, but I don’t know that you caught it. K versus Shift-K is a red herring. Shift-K does nothing as far as I know. The real problem might be this: when you’re doing that knife cut all the way around like in your screenshots, do you come all the way back to the beginning and click last on the first point you clicked? You have to close the loop completely, or it won’t make the cut all the way around.

Yes indeed Craig spotted one big thing… lemme dig on it and i be back in some moments :wink:

EDIT: SHIFT-K ( in the doc & wiki ) is intended to cut ONLY SELECTED faces.
Therefore it should work as K-KEY does after you do a A-KEY on a mesh with no hidden faces.
Finally it is not the case.
I created a blend ( lol it’s making 1,7MB and hace 6 verts and 2 quads :smiley: ) for the one that dont work on my 3 machines.
well well… i gonna spam again some screenshots and the blend to say more…

Ok guys. back there with some more info.
1st of all i owe apologies to all those i trolled ( on purpose, because i was kinda angry :wink: )
Finally Craig spotted one BIG thing about the knife tool, and i would say that i’m right saying it dont work, as much
as people like Craig who say it works.
In fact the 2 modes of the knife ( K-KEY that cuts faces, and SHIFT-K-KEY that cut SELECTED faces ) though part of the same
tool don’t both work. the K-KEY works fine, and the SHIFT-K-KEY don’t.
1st of all lets talk about the one that don’t work…

It is the one i ALWAYS (tried to ) use till now. Don’t ask me why i never tried the K-KEY, i didn’t even think about it and noone/nothing till Craig directed me to this option.
I tried the SHIFT-K on my 3 machines and none of them gave the proper result. I made a blend from the one i posted the 2 first screenshots and sends it to you:
knife_bug.zip (142 KB) in a zip format…

Please open it, go in edit mode, hit A-KEY and SHIFT-K-KEY the 2 faces. On 30ish tryouts i found only one that worked
on my laptop computer… Please confirm me this or i will become crazy and will have to find an oak for hanging myself :stuck_out_tongue:

Here, a shot of the blend:


now the SHIFT-K knife tryout:



I showed by editing the shot in gimp, the order of the mouse clicks i made for the cut. Note that the 1st cutting point never appeared to me. As you can see i made the cut in a counter-clockwise way.
( the following in the next post as i reached the attachement limit on this one… )

OK now the same file with K-KEY spamming ( here there are 3 different messy cuts. the mess is on purpose coming from me ):


the K-KEY on this mesh ALWAYS work ! and gives expected results !
Therefore yes, the knife works… with K-KEY, but knife don’t work with SHIFT-K-KEY :smiley: lol

Finally the obfuscation came from this page, that explains the knife tool:


I never saw anywhere, anybody saying the SHIFT-K-KEY dont work properly. Maybe because noone uses it…?
Nevertheless, i assumed that it did work fine as it is presented as a common mode of the knife in the documentation…

I have to say honestly that i’m DAMN GLAD you showed me today how to have a usable and usefull knife in blender !
Thanks to all for this !
But i think it would be fair to say in BIG RED LETTERS that only the K-KEY works as expected and that the SHIFT-K-KEY can be used at your own risk :smiley:
… till it’s repaired of course !

thanks again to all !
and have nice blends !

EDIT: Maybe Craig, for confirming or infirmin all that i said, can you try what you did on your mesh ( a multiple cut ) after selecting all the faces (A-KEY) and using knife with SHIFT-K-KEY and report all here ? This would be nice of you ( and i confess i would be kinda eased to learn i’m not totally crazy :smiley: )

I recreated your original topology and tried to make the cuts as you said you did:


and this was the result


I see that you already discovered what I did. I’m not sure why no one figured this out sooner, since it was pretty easy to recreate. The shift + K doesn’t work at all. It misses parts of your cut. You can draw out your cut and parts of it will not appear at all. Using the regular knife tool works fine, though.

Edit: Yes, I agree it was probably missed because no one ever uses shift + K. I honestly can’t think of a good reason for it.

I can also confirm that with shift+K it doesn’t cut the edges. The difference with normal knife is that shift+K has cut through (Z) option on by default and K doesn’t, and cut selected works when disabling that.
It might have something to do with that option and the mesh being non-manifold, but you could still report it, now that you have the example files to attach to the report and others can confirm it.

Xubuntu 12.04, 32-bit
Blender 2.66.5 r56054 - Shift+K worked without having cut through option on, not with it.
Blender 2.66a - had snapping problems with shift+K before moving the origin to geometry, worked without cut through option on after that.

Ah, that’s something i was completely puzzled with, as i was trying to cut for 10 minutes various of my models to see if i could reproduce your bug without a single time managing to have the knife failing.

And then i noticed that you used SHIFT+K, something i never ever think to use in my knifing sessions.

Indeed, SHIFT+K is simply horrible, failing a lot.

thanks JA12 and Sanctuary !!! you save my life ! :smiley:

I saw this option (Z) ( in the SHIFT-K-KEY mode ) and tried do play with it. I noticed it changed things in cutting behaviour but i also had some cases where it didn’t help, and some others where i needed to cut the mesh through Z ( though it didn’t work ).
In my current blend, i just used the K for cutting through Z and !!! wow, even on a complex mesh, i works very well.
I won’t have time today but i will report this as a bug. mebe the best solution is to remove the SHIFT-K option :wink: al all will be fine !

Imagine Sanctuary that i use the SHIFT-K instead of K since i use blender 2.5+ !!! now you can understand why i complain since so long about it :smiley: lol

have nice blends !

EDIT: now BEWARE YOU MODELS AND MESHES !!! I GONNA CUT YOU ALL EVERYWHERE !!! :smiley:

You’re missing my meaning. Shift-K works fine. K also works fine. Again, you have to close the loop (click again last on the first point you created to complete the box, drawing every necessary edge) in order for it to work. Shift-K just limits your cuts to the selected faces. So if you click on a face that’s not part of the selection, it won’t make any cuts there. The real issue here is that you were not closing the loop. Shift-K is just a specific limited use of the normal K function.

Notice in that documentation it says the Knife tool is accessed by K or Shift-K. The main description of the tool is for K. The last line (which you underlined) is a description of the Shift-K function. Both of them work exactly as they are described. You just have to close the loop.

Here’s your original screenshot again to show you how both K and Shift-K work:



The reason it didn’t work for you has nothing to do with Shift-K. It’s because you stopped at 6. You have to do click number 7. I just did a test using both K and Shift-K to make the same cut you’re trying in this screenshot, and they both worked perfectly. Shift-K may have some issues with really complex cuts, but not for this one. This is true for both K and Shift-K. The only difference is that Shift-K limits K’s function to only the selected faces. You don’t have to select faces in order to use K.

You’re misunderstanding. He -did- close the loop. It was skipping the cut; that’s why you don’t see it in the screenshot. I had to try it myself to understand what he was talking about.