When MMB Rotate Stops Working

I don’t have a middle mouse button so I set alt-rmb to act as mmb. But for some reason, perspective rotate won’t work now even when i relaunched the program. any suggestions?

If your “Emulate 3 Button Mouse” button isn’t pressed underneath the View & Controls section of the User Preferences window after you launch the program, press it and then use Ctrl+U to save the user defaults.

Let me know if that does anything for you.

thanks for the response. I wasn’t able to reset it to the right button, but I was able to set it to the left button. Could I have accidentally assigned something else to the right button.