When using Blender, audio clicks/pops

Not really a Blender-problem, but I have nowhere else to ask this question:

Win10 and nVidia updated automatically all of a sudden recently, and ever since whenever I enter Blender my background music played in VLC makes some click-noises randomly.

I have no idea whatsoever what is causing it, let alone how to fix this persistent problem. Please help me so I can listen to music while modelling, again!

The audio does not make this noise when Blender is not open.

I suspect this is a graphics card/driver problem, but I disabled nvidia audio completely in Device Manager (I’m using Realtek, and this driver did not update with the recent Win10 update).

I also set my PC to run 100 % both min. and max. in the advanced settings of my power settings.

My system:

  • Win10 64 bit
  • Titan + 1070.
  • Realtek onboard.

i dont why this just started happening, but i know this can happen when your pc runs out of cpu power. maybe the windows update broke your graphics drivers and for some reason its rendering on CPU?

No, it renders fine with GPU. Both cards are rendering fine.

The odd thing is, this audio problem is only there when I am using Blender, ie. modelling. If I leave Blender open, but don’t use it, the audio is not having any problems.

The click/interrupt-noise only begins randomly when I’m using Blender.