Whenever I open Blender 2.82,It crashes at startup and the icon in the blender directory disappears

Whenever I open Blender 2.82a, It crashes at startup and the icon in the blender directory(where I installed Blender) disappears and whenever I install a new version of blender, again the same thing happens and I’ve also tried it with Blender 2.83, I have no antivirus installed. I have also tried to open it with command prompt and it opens but the problem is that I can’t always open command prompt and open blender because it is time-consuming than just clicking on the icon. When I install a new version of blender, I first try to run it from the command prompt and it works also but then afterward when I try to open it from blender.exe file in the blender directory which I have installed on my D: drive, It crashes at startup and the icon of blender.exe file disappears from the blender directory in D: drive. How can I solve this problem? Please reply and can I use any third-party uninstaller to uninstall it completely

GPU: GTX 1050Ti

DRIVER: latest

OS: Windows 10

PROCESSOR: Intel i5 9400F @2.90GHz

I noticed that when I install Blender on my C: drive, It works but when I install it on my D:drive, It just doesn’t work but before it was working when I installed it in my D: drive. Is there any way to make it work when it is in my D: drive only?; because my C: drive is an SSD of 240gb and if I install blender in it, my PC will become slow.

edit: now it’s not working on C: drive also. When I run it with blender_debug_gpu, it works but when I try to open it with blender.exe file, it crashes and the blender.exe file disappears.

You have to delete Blender prefs from a app folder somewhere in windows. I’ll check.


Delete those folders and then install again.

Tried but nothing happened and the same issue arrives.Any other way to resolve this issue??

I’m sorry. I can’t help you. It’s strange that it crashes after a clean install.

Edit: Maybe it’s the graphics drivers? Some people have reported problem with the latest drivers from nVidia. Maybe you need to have older drivers.

I’ve latest drivers.
EDIT: Before I had old drivers and at that time it was not working but now when I updated the drivers, still the problem persists.