Where did the buttons go? I can't find 'em!

I’m working on a game. I don’t know how it happened, but all the buttons in the buttons window disappeared. I maximized the buttons window after about 15 minutes of moaning to find the buttons way up at the top of the window. I tried to move them down, but they wouldn’t move. I could move them up, though(?..). Also, when I press “W”, a Boolean window appears with the options : Intersect, Union, and Difference, instead of the window with the options to Subdivide, Remove Doubles, etc…why? Please, if you have any idea on how to fix it, any inkling at all, let me know. Thank you.

Not sure about getting the buttons back, though I think I had the same thing happen to me at one point and I want to say that there is a hot key to re-center the buttons, but what it might be I could not say.

In regards to the ‘w’ menu you get the Boolean menu rather than the Specials menu when you are in object mode instead of edit mode.

…oh, yeah…

…I guess I was in Object mode. With the mystery of the vanishing buttons and all, I guess I just wasn’t paying attention. Thanks, Alistair. Once I figure out how to recenter the buttons I’ll be a happy camper. Is there a list of all the Blender Hotkeys anywhere, or does anyone know what the hotkey Alistair was referring to is?

Edit :

I fixed it. I just right-clicked and changed the panel alignment.

Right click in the buttons window and pick the button alignment you want from the popup