Where, exactly, does a "library override" now show up in the "Blender File" outline?

… and, does it have or need a “Fake User?”

I’m still trying to shoot-down a problem – involving some “very old” Blender files – in which I do the following. Only to find that the keyframes that I have set disappear when I reload the file.

• Create new blend file, link to “scene” from the “sets” subfolder, specify as “background set.”
• Link to a character asset as a “group.”
• Create a library override.
• Position the character in two places, and set keyframes for each in the timeline.
• Observe that the group moves as expected.
• Save the file, then “revert.”
• The keyframes are gone, and the group is in its last position.

When I try to re-create this with a “default cube” linked group, I don’t see this. But I’m also seeing some apparent differences based on “exactly what” I am trying to keyframe. (Am I keyframing the linked group from the library, versus the library override?) Things like this. Any suggestions?

Youthville_Set.blend (1.5 MB)

miranda.blend (1.6 MB)

Okay, here are the actual assets. Circa five years ago. I create a file and link to “Youthville_Set” as a background image. Then I link to “miranda.blend” as a collection, then create a library override.

Now, attempting to animate the library override, I place it at two positions 100 frames apart and insert keyframes. Then, I save the resulting file and “revert.” When I do, the keyframes are gone.

I’m at my witt’s end at this point. It must have something to do with the files, which are quite old now.

Hey ! Indeed !

What version of blender are you using ? I’m with a master build from 2/3 days.
I didn’t investigate much the file, but I didn’t find anything particular at first look…
Sound like either we are missing a really obvious point, or it’s a good candidate for a bug report…

Just linking/override collection of the character in a fresh new file didn’t work.
Maybe it’s worth testing with a cube parented to an armature and see if that works…

The versions of Blender which produced these files are now very old, but the version that I am now using is the most-current one. The sequence of events is this:

(1) Open a new blend-file. Link to the “Youthville_Set.blend” file, select the scene, then select this scene as the “background scene.”
(2) Link to “miranda.blend,” choose the “Miranda” collection.
(3) Create a library override.
(4) Using this override (I think …), create two keyframes about 100 frames apart.
(5) Verify that it looks as expected. Save the file.
(6) Now, “revert.” Upon this, observe that the keyframes are now gone and that the override “Miranda” is at her final position.


Of course, the very first thing that I thought of was to try to re-create the problem using “the default cube,” but when I did so everything appeared to work: there was no difference when I “reverted.”

I have now fiddled-with this matter for quite some time and it is for this reason that I offer you the files.

I now cordially ask the community to actually-download these actual-files, then try yourselves to recreate the actual scenario that I have tried to describe using these files. I really am “at wit’s end” on this … thank you all in advance.

My right hand is right now poised just above my forehead, and I am right now poised to say … “d’oh!” :smiley:

Still hoping that anyone, now given the actual files in question, can finally point me towards the solution. Many thanks in advance, because so far this sure-as-heck is vexing me!

Ok !

The issue is related to NLA editor, if I get rid of everything there in the original miranda file , then the animation is kept when linked/overridden in the shot file.

I let you investigate further if needed… As the file is old, maybe it behave differently with a new NLA track from ~blender 3.0 !

char.blend (261.4 KB)
shot.blend (154.9 KB)

Good luck !

My intent was to put NLA strips into Miranda to then be able to link to those in the shot files. But it may well be that something has changed about NLA information over the years. Thanks for the tip … I’ll pursue it and circle back with what I find.

What “really blew me away” about this is that the keyframes that I had set … disappeared completely. I had not done anything at all regarding “NLA,” and I still don’t fully understand why it became a factor.

My wild guess is that something isn’t properly overriden in the NLA, and when you reload the file it’s restored to the original state.
Maybe when you use the NLA, it takes over the action editor, so the hierarchy is kind of NLA → action editor → rig .
If one of the above isn’t properly overriden you loose the animation.

Maybe it can be more simpler to create the NLA tracks in the shot files. And then duplicate the shot if you need several ones. It should work properly then.

I indeed find it very weird that the animation disappear, but intuitively that makes sense, both NLA and action editor are related to animation.

By investigating a bit more on all that you’ll probably find a clearer answer !

I can’t do this project without NLA. I have to have my character to be “walking, and swinging her arms,” as she moves from one keyframe to the next. None of the defined actions have anything to do with the character’s position in 3D space: only with her facial expressions and arm/leg movements.

The shot-files that I have attempted therefore only used NLA tracks for arms and legs. I still now feel, upon review, that keyframes concerning physical position should not have disappeared … especially since in my latest attempts I did not(!) attempt for her to make “arm or leg movements.”

I literally just linked to the set and then to the character-file, placed a character-override into the “miranda group,” and then tried to move it from one end to other. I did not attempt to make her walk.

Well, I hope that I have not just been “barking up the wrong tree” here, for lack of firm understanding of the latest user interface changes. Here is an example of a shot-file that appears to work as I intended. There seems to therefore be some confusion on my part as to the specific step where I attempt to create a library-override for the “MirandaGroup” collection and then attempt to move it. Superficially there seems to be “more than one way to move it.” Now realizing that it is probably user error, I’m trying now to reproduce both the scenario that now seems to work, and the one that I had previously described. (I’m sorry that I did not also post that original apparently-failed shot-file at the time.)

shot5.blend (943.2 KB)

I have now observed a few more things:

• The “I-KEY,” when used in various windows and in various contexts, does not produce the same options. And, it appears to matter in which window I am pointing the cursor.

• If I attempt to animate “MirandaArmature,” even though it looks good when I save the file, the keyframes are gone when I “revert” back to it.

• I also get an error: “No usable context info for active keying set.” This is probably part of my problem.

• Sometimes, the “I-KEY” displays a menu which contains only three items … but none of them seem to work.

• The fundamental problem still seems to remain: I can place keyframes, for various objects in the “MirandaGroup,” but most of the time they disappear.

• I can only achieve success if I press “A-KEY” to select “all” things within the group. But then, I effectively can’t use NLA to make the character walk, wave, etc.

I appear to have finally found something that works, although I invite further explanation:

• Set the keyframes.
• In the Action Editor, choose New Action.
• Click the “fake user” button.

1 Like