Where is my cam? 2.8

Something strange. Some objects disappeared, the camera too. Instead, such a thing. Is this a bug or am I pressing something wrong?

Probably several things you could have done accidentally. Hidden them, disabled the default Collection, etc. If you can’t find them then you can share the .blend file and we can help search.

You have probably pressed Alt B.
That shortcut allows to restrict visibility of scene to a cone corresponding to a clipping region defined in current view.
To go back to normal , press Alt B again.
Or
Go to View menu > View Regions > Clipping Region.

Could it be that it’s a blend file from before the UI change was made to hide the viewport rendering indicator by default? I had exactly the same problem where, before the change was made, I had disabled rendering of the camera in the viewport but, some time after the change, I needed to move the camera but just couldn’t find it in the viewport. The camera was shown in the outliner and if I pressed Numpad 0 the view zoomed to a likely position for the camera, even though there didn’t seem to be anything there.

To fix, it, I clicked the little funnel icon shown in the screenshot and clicked the “Disable in Viewports” icon in the bar across the top of the dropdown menu (looks a bit like a television). After that, I could use the vieport visibility toggle on the camera, so I could make the camera visible again for easy repositioning, and then switch it back off so that the viewport only showed me what I want to see.

Hope this helps.

image

It’s was Alt+B. Thanks, zeauro