Which version of blender??

Hi everyone
I have an Apple Mac OSX version 10.5.8 and I was wondering which Blender version would be compatible with it.
I have done some research but some places say you it’s 2.58 or something and other places say it would work with 2.64, so I thought it would be better just to ask rather than downloading the wrong version.

Thanks

I’ve been using 2.68a on my MAC, but I think I have a newer version than 10.5.8 - I’m not at home to check.

I think it says you need 10.6+ on the blender website

Moved from “General Forums > Blender and CG Discussions” to “Support > Technical Support”

Thanks for moving it, I wasn’t sure where to put it :slight_smile:

Please reply, I really need to know which one

It’s OK now, I have found the right version.