White Artifacts help!

I’m having trouble getting rid of white artifacts around the mouth area.


My rendering settings are with Blender 2.61 + Internal renderer with approx + pixel catch + falloff adjusted.

The material on the face has sss and is textured. There are no inner part of the mouth.

What is this white artifact and what’s causing it? The eyes are made similar to the mouth but how come no white artifacts appear there but on the mouth instead?

Please help.

To me it looks those are not white artifacts but a lack of geometry, better known as holes :slight_smile:

You said you got no oral cavity, just the lips. If you use a subd mod it might look alright in your viewport with 0 or 1 as preview but if the subd level is set higher for render, the loop where the lips end inside the oral cavity might be pulled outwards - it can happen at extreme geometric deformations like the corner of the mouth.




Hi, I’ve been stumbling with this issue to for a while too, on previous works it didn’t matter so much, but in this one I need it to work correctly.

As I show in the pictures I have those white artifacts surrounding certain objects (also a few black artifact but I the white ones are freaking me out), they are low poly and don’t use subsurf, I’m also sure all those parts are closed, so I don’t know whats going on. In a previous project I thought it was because the surrounded object was a fake three (a plane with a three texture). It’s starting to be really annoying.

edit: Damn the images got too downscaled… if you zoom in you can still see a bit the artifacts.

Your problem seems to be a different one if I spot it right and that’s rendered with BI… (I am pre-morningcoffee :slight_smile: ) :

In BI those white edges appear if you have turned on z-transparency and the camera frustums near and far clip are too far apart so the precision is too small and z-fighting appears. Might be a hot trail.

As for the tree you most likely forgot to turn on premultiply alpha and if not, it’s the same problem as stated above.

I recommend to turn on the camera distance to be displayed in the viewport and set the near clipping plane as far away as possible and the far plane as close as possible.

Thanks for the answer! You’re right, I’ using a lot z-transparency (although only on the statues and table cloth) and my camera distance is 80 to see everything.

But this church is way too long and I can’t set the near clipping farther than 5, is there another solution?



Also, as shown in the pictures, I made the clipping from 50 start to 70 end and it still shows the hot trails. Are there other possible solutions?