White Lines around leafs?!?!

Alright so im making my very first Tree and I have these darn lines around the Leafs. I followed this http://www.cgtextures.com/content.php?action=tutorial&name=alphabg but it still does not work, any ideas?

The Tree

and the textures I made in gimp for the leafs.


In the Texture / Image panel try selecting the Premultiply checkbox or in the Render / Shading panel set the Alpha value to Premultiplied

Thanks for the reply, but it didn’t work.

Under the Render->Anti-aliasing settings, turn on ‘Full Sample’

i tried it with your files, i couldn’t duplicate your exact problem, but the “correct” settings for the mask image appear to be to turn off all the use/calculate/invert alpha checkboxes under image sampling, and either set the alpha influence to -1, or 1 with “negative” checked in the influence panel. then just make sure you have transparency turned on for your material and the alpha for the material set to 0. either that or set the material alpha to 1 and set the alpha texture’s influence blending to multiply.

it can get confusing because as you can see, there are several different ways to do the same thing. its helpful to have these options to build more complicated materials, but if you’re trying to learn, the having half a dozen checkboxes that need to be in agreement with each other can easily become overwhelming! good luck!

Thanks both of ya! Ill give that a try.

I fixed it! I had to Change the RGB color to green (it was white before), no idea why that was causing the problem. but hey as long as it works!