White objects in edit and object mode Blender 2.69

I have a strange problem after upgrading to 2.69. I have a pc and a lap top, I’ve been running blender 2.65 with no problems swapping and copying files between them. After upgrading to 2.69 all works fine on the pc but my lap top will not show textures in object or edit mode. I’ve checked all settings between the computers and there is no difference that I can see. Please note that I reinstalled 2.65 on my lap top and the problem happens in that now, although going even more retro 2.49 is ok. So you can say I’m rather confused! Just to note the pc is running windows 7 with a 64 bit version of blender, the lap top xp with the 32 bit version. I’ve attached examples below.



Cheers

Simon

I’m guessing that you may need to (re)associate the texture with the object in the Image Editor where you unwrapped the UV’s, should be as simple as going into Edit mode and selecting the right image from the drop down…?

solved it! Must be something to do with the graphics card on my laptop. I went to preferences in blender, then system, the area marked OpenGL and un ticked GPU mipmap generation. All works fine now and what it does exactly I couldn’t say!

cheers

simon