white patches in mesh

once again Hi all
i made a simple mesh model… after that i colored it with material tab…every thing was looking fine but as soon as m using subdivision surface m noticing theirs white spaces coming in mine model tried lots of stuff checked on net tutorials but nothing able to fix mine problem…but it seems i don’t even have idea how to fix this problem :spin: here .blend file screenshots attached hope it will explain better thnx in advance

Attachments

whitePatch.zip (603 KB)



You have doubles around the elbow, select everything, hit space --> remove doubles.
Clean up the mesh around the pelvis, use only quads and tris, don’t use ngons on organic models.


You have loops of zero width faces the go around the arms and legs which apparently didn’t get selected when you added the green material. Turn on adjust cage to modifer for the subdivison modifier, so you can better select those faces, and assign them the proper material. Or disolve those edges, if you don’t want them.

Huge thnx both of u bros u guyz solved mine problem :slight_smile: god bless u guyz