White shapes in Texture mode / other questions

c_pocketwrench.blend (665 KB)

Hello, I am making a small adjustable wrench model, but I’m facing some problems.

  1. Texture mode in Viewport renders completely white shapes.

    If anyone could tell me why this is happening, I’d greatly appreciate it.

2)N-gons.
http://i.imgur.com/NSZqEBh.png
http://i.imgur.com/8765Xjd.png
http://i.imgur.com/INIa1VQ.png
The model is going to be textured and triangulated, but I have n-gons. Everywhere.
It’s also ‘width-ified’.
http://i.imgur.com/3GJgPXL.png
It’s going to be a nightmare to solve; can anyone give me tips to help these n-gons? Knife tooling them to make quads and tris makes the lighting all funny.
I’m also going to move some edges in the Y axis, like:
http://i.imgur.com/UTtilMw.png
but currently there’s too many edges and the n-gon face makes the result look horrible.

  1. Edge work
    http://i.imgur.com/InvdbWA.png
    Currently the edges of the entire model are rigid. And look sharp and unnatural.
    I know of the bevel tool, but it doesn’t work well this this shape.

Could anyone propose a fix for this please?

Thanks guys,
I’ll really appreciate any help that’s given!
I’ve also attached the .blend file so you can have hands-on look.

You can convert N-gons to tris with ctrl T. However, if you want to refine your mesh, I would suggest redoing some of the modeling, and this time avoid n-gons from the start, and stick with quads. Since you already have the shape, you can use retopo tools to construct a new mesh, and using grid fill tool can speed things along. here are the steps of retopo-ing a mesh:

place your vertex, or vertexes in front of your model, then press the button on the main header that looks like a magnet.
In the options to the immediate right of that button, set it to ‘face’.
more buttons will now appear just to the right. press the one that looks like a square in front of a circle.
you can retopo at this point. if you move the vertexes, they will snap to the model surface underneath.
but in order to see things better, you should go into object buttons >> display settings >> x-ray
then, in your 3D window, while in edit mode, press N for a whole new set of buttons, and find the one that says ‘hidden wire’ in the shading panel.

Thanks for the reply. I followed your instructions. Then… what do I do?

What exactly is re-topo-ing? I assume its something to do with reforming the topology but why should I do that?