who turned out the lights

After you upload the file it goes to the download page for that file. Then you give the link to people, like so:
http://********.org/blend/3446

The problem is that in 2.49b the file opens in Shaded mode and in 2.5 Shaded mode doesn’t exist so it opens it in Solid mode which neither in 2.49b nor 2.5 shows the spotlight. Note that when you press P the spotlight shows up. I don’t see a way to get the spotlight to show up in the 3D view unless you can use the GLSL setting instead of Multitexture in Textured mode.

what’s P do?

So what are you saying, exactly? How do other people see spotlights in their scene?

P starts the game engine.

No idea why, but if you delete the UVTex from the Ts and go in Textured mode you can see the spot light:
http://uploadingit.com/d/YR2G0CXLCYUJKDFL

Yes I see the spotlight in that file! But what did you do?

Here is what I tried to duplicate what you did. I must have done something wrong because I can’t mimic your file.

In the Display pane of the main window , I checked ‘Textured Solid’. This changed everything to grey.

Then I tried selecting each object and then found something called UV texture in the properties window, when you have the triangle icon selected (Object Data). I hit the minus button to delete the UV texture that was there, and it did cause my objects to switch from all-grey to their proper colors. But it didn’t turn on the spotlight.

Can you describe what you did differently?
Thanks!
Bob

  1. In the header of the 3D view right to the right of what mode your in (Edit mode, Object mode) is a dropdown of the view method. Change that to Textured. Everything turns white.

  2. Select a T and go to the Data panel in the Properties window (icon is 3 connected vertices.) In this panel find the UV Texture box and delete the UVTex there with the - button on the right.
    Do this for the other Ts.

OK got it! Thanks! Finally it works.

Bob