Why are dimensions not preserved?

I want to build a bar cube that’s 15cm x 3.2cm x 1.6 cm and for this, I add a 0.15m cube and resize to 0.016m on the Z-axis but when I measure I get ~0.48m and ~0.023m. What am I doing wrong?

Please see the video below:

Getting:

Well this is awkward! The page you are looking for could not be found.

And you are resizing in edit mode? Resizing is a factor… how do you resize to 0.016m ?? And why do you then measure two numbers ???

You have to scale in Z by 1.6/15= 0.106666 and in X by 3.2/15=0.213333

1 Like

The video is not working.
But it sounds like some sort of scaling issue.
Check in the n-panel what your scale is. If it is anything other than 1,1,1 then you might simply have to apply the scale to resolve your issues.

The reason why you have to apply scale sometimes is explained here:

1 Like

I’ve changed my video link, sorry about that. Didn’t know that resizing is a factor, I thought I can resize using my current scale, in meters. I am new to Blender and I love it but I struggle with basic functions such as this. I’ve made my first donut tho’ :slight_smile:
PS: I am trying to make an object I can print on my 3d printer so I need those exact dimensions for my object.

Nevermind. Tipp: blender does have an non enabled addon MeasurIt and also a 3D-Print Toolbox which also could be usefull for you.

1 Like

If you want to set the dimensions on an object, press N in the viewport to bring the side panel, then in item, you will have a ‘dimensions’ property. Set your size here and then apply scale.
image

As a general rule you should always apply scale after creating it.

Objects without applied scale can cause unexpected behavior for modeling tools, modifiers, shaders, textures, animations, constraints and rigs, scripts an on and on.

The reason you are getting .48 and .023 is that the units of measurement are set by default to Meters in the scene properties…if you want real-world scale set the Unit to the measurement you are working with ie: CM…

set the unit scale to .1 if you want the unit scale to stay in Meters…the display will show the real dimensions…
that way you don’t have to calculate what to call the object to…just enter the scale directly in CM…

You still will have to apply scale as you changed it…