Why are my UV textures shadeless in the Game Engine?

I have a UV-textured enemy for my game. Set Smooth is on, TexFace is off, Emit is 0, and the UV texture is only mapped to color. When rendered, it has correct shading. I’ve tried both Blender multitexture and Texture Face settings in the Game menu (my computer can’t do GLSL), but when I press play, the character is shadeless. His eyes are normal, and they aren’t UV-textured, so I’m pretty sure it’s something to do with how I’m mapping the UV texture to the mesh or my material settings, but I can’t figure out what. :spin: Help!


is there a light on the same layer as the enemy? i seem to remember this being important…

Go into edit-mode and enable Light mode (press the Light button, in the Object tab) for all of the faces on your lit objects.

Ok, so I activated TexFace again and enabled light mode for each face, and it worked! Yay! Thanks for your help. :slight_smile:

No problem.