Why are not all particles/children getting shadows?

Hi,

I’m new here (glad a forum like this exists!) and hope I’m posting in the right place.

I’m working on a desert scene. For the grass clumps, I’m experimenting with different ways to get shadows. In the attached blend file (and in the attached snapshot), I’m using a spot lamp (“Lamp Shadow” object in the attached blend file) Deep Buffer Shadows to generate shadows. I know my settings are way off for now (shadows don’t look good at all, yet), but I’m wondering why it seems like not all the grass clumps (all the grass particles/children) are receiving shadows. If someone has any thoughts, they’d be greatly appreciated!

Thanks.

p.s. - having trouble uploading the blend file. I’ll keep trying.

Attachments


Here’s a link to the file:
https://www.dropbox.com/s/frgcl12mlb7fix8/Desert3.blend?m

I think I found an answer to my own question. Posted by someone on another forum:

“If I place them too far, there is - depending on the settings for SpotSi, ClipStart, Samples, Bias, and Soft - either a leakage of light through the walls, or the light is broken down into its individual scanlines (so the scene is lit as if through a venetian blind/jalousie).”

So it seems that if the spot lamp is placed very far away from the scene (as I was trying to do in my scene to more closely emulate shadows from the Sun), the shadows look as if they’re lit through a venetian blind. That’s what the shadows seem to be doing in my case. Posting this in case this helps someone else (or in case anyone else has any other insight into this).