Why are objects behind my intended object being selected?

Hello Blender users,

I am a 3ds MAX primary user, and I’ve been learning Blender 2.8 for the past month. So far, I’m getting the hang of it.

My issue is something that started to occur out of nowhere. Whenever I go to select an object, usually in the foreground, objects behind it are selected instead. Is this a setting I accidentally hit, or is this a bug in Blender’s coding?

I’ve included a video of the demonstrated issue. Any and all help is appreciated!

Solutions tried unsuccessfully: Updating graphics card, uninstalling and reinstalling Blender 2.8, “select through widget”,

Check setting in Edit / Preferences / Viewport / Selection - OpenGL Depth Picking.
Description says if unchecked: ‘the front most object may not be selected first’