Why are the Particles not Rendering as I see them?


  1. In Blender 2.5 the particles are emitting from a plane and going up vertically, but when I render I just get this. Why isn’t it rendering what I see in Blender?

  2. I am using a cube object as a particle object. Is there a way to give the cubes different colors?


I’m not sure what you are trying to do with those cubes, but I just released a 2.49 script and BLEND file that makes an array of cubes transition between photos on each side of the cube.


I too would like to know how to make the same object in a particle system different colors. The only way I know how to do it is to make a bunch of copies of the same object, add a different material to each one, then add them all to a group. Make the particle system pick randomly from the group and you will get different colored particles, but control is still lacking. What if you wanted to color the array with a gradient or something?

Thanks Atom. I like your “Transition” video.
My image is nothing spectacular, I just want them to render like they look in Blender. In Blender the cubes are all spread out like an explosion, but when I render I only see what’s above. You don’t have to “Bake” them do you?

There must be a simple setting I am missing.


Try moving to the first frame, then moving forward again. Sometimes it gets ‘stuck’ and renders the image as if none of the particles have been emitted.

if you haven’t baked your particle flow to a permanent cache, then the simulator dynamically figures out their position, based on where they were the previous frame, and saves it in a temp cache. If that previous frame data does not exist, it cant figure out where the cubes should be. Hence like what .mesh said, you need to either a) bake or b) press ctrl-A from frame 1 or b) manually go to frame 1 and arrow forward frame by frame.

Keep in mind that as soon as you change ANYTHING, that temp cache gets invalidated and deleted.