Why BGE use lot of CPU when running game in idling state?


(blenderaptor) #1

Press P, my game is in idling state. Nothing is running. No always sensors, No pulse modes, so why the heck my game makes my CPU climb to 20% ?

Its super annoying


(TheDave) #2

It’s not really idle. Every ‘frame’, the game engine goes through a loop which involves detecting inputs, python, rendering, etc, and that happens even if you are not shuffling things around on the screen. The fact that nothing is going on just means the engine can go through its frames faster. Normally you WANT it to have the highest FPS possible, which means using a lot of your available resources to do it.

As you add more into your simulation, you should notice your frame rate decreasing, rather than more of your computers resources being used. That of course entirely depends on what you’re doing as some things will use more CPU,GPU, I/O, etc, but generally speaking should be true.


(wkk.py) #3

If you use UPBGE the issue should be less extreme: UPBGE will process everything it needs to do for each frame (usually 60 frames / second), and then sleep until the next frame.

Thanks to that sleep your CPU is not at 100%.


(blenderaptor) #4

Answer :

  • in the game menu : turn off the “Record Animation”
  • in the Proprieties Panel , Render tab, System part : uncheck " Use frame rate" and set “Vsync” on “Off”…

wohoo … my fan doesnt scream when i launch my game !


(- Click for resources) #5

unlocking all the fps your video chip/card can deliver, this would make your card only noisier lol, and it can even add coil wine to the noise.

But then again, it has almost nothing to do with cpu(unless you the use onboard video).


(blenderaptor) #6

yes, reading the description made it curious. But the fact is, my CPU activity drops under 10% now and my fps remains at 60… so … :smiley:


(- Click for resources) #7

well good that you have a solution, but uhm stays at 60? that can’t be, or are you capping/limiting the fps by the driver as well?


(blenderaptor) #8

Scene tab in Propriety panel : Physics steps - FPS setted to 60. That’s all.