Why can I no longer pan?

Done clicked something I shouldn’t I think, and n now I can no longer pan/rotate view while in 3D view. I can zoom and everything else seems fine, but I can no longer pan. If it helps, I think I was clicking buttons in the lower left corner of the keyboard when this happened.

View isn’t locked to cursor, still can’t pan in a new viewport, still can’t pan in other files…
Any ideas?


Assuming you may have reset your mouse buttons? accidentally
Try spacebar to get the command search started, type “pan” and see if the suggested pan command works without a hot-key, or use Ctrl+Numpad2 (4,6 or 8). If those work, most likely you just messed up the hot-key.
If that is the case, Edit>Preferences find the key maps and reset to default (if you have customized, you need to look for the specific one, so that you don’t reset your customizations)
The worst case is, it’s a new PANdemic…

1 Like

I had changed it to a custom button while ago (numpad /, aka backslash) and it’s still set to that in my preferences. I tried clicking the shortcut edit and clicking numpad / again, and the button press doesn’t even register in Blender. It has become numb to the numpad /…
Changed it to middle mouse again, and that works. It seems more like the issue is Blender is blocking keys. I think this is the same reason I changed it from middle mouse to numpad \ to begin with.

So… kinda solved? But it seems the issue isn’t completely gone, it’s just a different issue from what I posted.

The backslash is a useful Blender hotkey, that toggles in and out of Local View (unless you reassigned that too, you will be missing functionality) - I assume you programmed a different key for each pan direction?
Now that I think about it, the reason it did nothing at all maybe that it both conflicting key assignments exist concurrently.
Assuming you are new to Blender, may I suggest you do not hurry to reset keys until you get a broader understanding.

It may just be the Scroll Button is worn out, for scroll clicking. I wore out a couple already over the years, as you figure that is the most used button on your mouse…check it in another program and see if it acts the same as in Blender. I was able to re-map as I have a 5 button mouse.

Another thing that may happen (more data needed) is that a new add-on may hijack a key.

That’s my story, anyway.

Could you have turned Num Lock off by accident? That would change how the num pad functions, easily accidentally pushed.