Why can't I change the bone rotation type from ZXY Euler to something else?


(simplecarnival) #1

I’m working with a rig generated by BlenRig and was wondering why a particular bone rotation is using ZXY Euler and can’t be changed. The dropdown showing the rotation type is purple. I am able to click on the dropdown and see the other options, like Quaternion (WXYZ) and XYZ Euler.


Any idea of what’s going on here? How can I change the rotation type? Other bones in the rig allow me to change the rotation type (and are not purple).


(Hadriscus) #2

Purple means it is driven by something - something, somewhere in that rig, controls it. Open the graph editor, driver mode, open the sidebar and see what is in control of it (driver tab).

Hadrien


(simplecarnival) #3

Thanks, Hadrien! It appears that there’s a ton of drivers in this rig, but at least I know where to start looking.


(simplecarnival) #4

Follow-up question: Where can I find the root of where this driver is inheriting the rotation type from? Here are the steps I take:

  1. Select the bone (arm_fk_L) in Pose mode
  2. Open up the Graph Editor
  3. Choose the Drivers from the dropdown
  4. Select “Rotation Mode (arm_fk_L)” on the left panel of the Graph Editor

On the right panel under the Drivers tab, if I click the “Remove Driver” button, the constraint will be removed and I can choose a different Rotation Mode. Still, I would rather keep the drivers in place and switch this bone to use Quaternion.

On the right panel, I’m not quite clear what the Prop and Path values do in the variable; if I look at the _rig object (it’s the armature that the bone belongs to), I’m not seeing an obvious spot where it’s inheriting the ZXY Euler Rotation Mode.


Any idea where I should be looking?


(Hadriscus) #5

The path points to the specific property that controls the driver. It is a property named “ROT_MODE” on a bone called “arm_fk_L”. You can find custom properties in the n panel.


(simplecarnival) #6

Wow – found it! I would have never thought to look there. I see the ROT_MODE property, and changing it to 0 changes the Rotation Mode to Quaternion. Thank you!


(simplecarnival) #7

Hadriscus – I’ve run into what seems like a side effect of having changed the Rotation Mode to Quaternion and then back to its original setting, back to ZXY Euler. It seems that the bones where I made those changes have stopped working on a Linux system. However, they still work on a Windows system. I’ve posted about it here. If you have any ideas on what’s going on, it would be greatly appreciated.


(simplecarnival) #8

Never mind – got it working!


(Hadriscus) #9

Well okay, great ! What was the issue ? You know, to help time travellers ?
Ah nevermind, you wrote the answer on your other thread. Autorun python script. Classic ! :smiley: