Why can't I get ray traced shadows to work properly?

Hi,

I don’t know what is wrong but for some reason the ray traced shadows will not work correctly with this setup. Do you know why?

I have a particle system set-up on a mesh that replicates a hex cylinder object on each vertex.

I have tried everything I can think of and am wondering if this is a Blender bug or a misunderstanding on my part?

Any suggestions much appreciated.

Cheers

Blend file attached.

Attachments


HexCylinder5.blend (525 KB)

I put some more shadowcasting objects with the same material in to cast some obvious shadows and only got a shadow on the front object.

The emitted objects really dont receive raytraced shadows and I cant find any wrong material or light settings so I cant say its your fault :stuck_out_tongue:

Spotlight with buffered shadows work perfectly though, you should consider using those unless you really really want them to be raytraced for some reason.

The main problem is that you have overloaded the scene with particle objects. You have 640 particles overlapping so Blender is producing render anomalies because meshes are being generated on top of one another.

Check out the attached scene. I was able to reduce the particle account significantly. This may not be your intent for the scene, but it does bring shadows into play.

I also enabled the rendering of the emitter itself. This gives a place for the shadows to fall upon as well.

Attachments

HexCylinder5.blend (282 KB)


Thanks guys for your help! It was very confusing but now I understand what I did wrong.

You taking your time to look at this is much appreciated!

Cheers

why not dupliverts to duplicate the hex cylinder on each vertex? I’m not sure, but I think I once heard that the particle system (at least hair) doesn’t play all that nice with raytracing. Try dupliverts then: parent your hex to the “emitting” object and in the Anim settings tab (F7) for the parent object, activate dupliverts. Should do what you’re asking for without any ratracing issues.

Thanks for the suggestion. I tried that as well and it kind of works but didn’t give quite as much control as I needed of the individual cylinders.

Cheers

Hi Guys,

Here is a small image showing the basic concept. I’m still not entirely happy with the render but I think I can use it now. Maybe I need to consider using an external renderer with GI?

Cheers

Attachments


Looking very good as it is, but if you wanna try some external renderer, I suggest Lux.

Nice flare in the ring. :slight_smile:

what problems are you having with the look of it, like, how do you want it to look different?

The main problem is that I wanted a softer look to the shading. So I finally forced myself to try the yafaray renderer and GI. This produced the look I was after for this scene and was relatively easy to use. Now I find myself checking out LuxRender and Aqsis!

The disadvantage of this is the limited ability to use the compositing nodes for all the render passes i.e. the glow effect (which I know is a “cheat”).

I hear there is a possibility that 2.5 will make this process easier :slight_smile:

(Note: the original image is 1920x1080 and all the cool detail is lost in the thum image :-()

Attachments


you can use soft shadows on rayracing, if you turn up the samples from ‘1’ and make sure the soft size is up a bit you can get really gentle shadows. I don’t know if you know anything about gamma-correcting, but if you used a linear workflow to your picture, it would probably also help quite a bit.

http://www.ypoart.com/tutorials/tone/index.php

a bit of gamma correction might help in bi…

Yeah. I converted over to a linear workflow and added gamma correction at the end. It did help improve the overall image however I would need to spend more time adjusting the lighting to get it looking better than the yafaray render :-(.