Why can't I reassign the layer visibility keys?

I use Emulate NumPad always. But it would be nice to still have a layer visibility shortcut.
But for some reason when I assign hotkeys for this it doesn’t take. Or the align view settings are overriding them.

Why would the configuration in the screen shot below not work? What should I do instead?
I’m pretty sure the shortcut [Q 1] is not taken already…


Thanks

For the align view shortcuts you could change them from ‘Press’ to ‘Click’

Thanks. But what if I want to leave the Align View keys as they are but set the Layer Visibility keys to be something else? Is it possible?
I tried setting [Click 1] for Layer 1 but it didn’t seem to have any effect.

I think the solution is going to be turning off Emulate NumPad and manually remapping everything to behave as if it were enabled.
It’s a pain but I will have the configuration I want in the end.