Why do certain faces refuse to emit hair?

I am basically following this tutorial step by step to add hair to a character I have been working on.
http://www.blenderguru.com/videos/how-to-add-hair-to-a-character/

I have set up separate vertex groups for the left and right sides of the scalp. There is a strip of faces which don’t want to emit hair, and I have no idea why! These faces aren’t really any different to the faces which are right next to them, which are emitting hair.

As a test I even made a separate vertex group out of only the faces which were not emitting hair. I assigned that vertex group to the particle system under the “density option” and they still didn’t emit hair, hair just grew around them, like they’re some sort of an infertile desert wasteland!

Here is what is happening. Note the strip of baldness, as if someone just took a buzzer to her scalp and shaved that one strip. Maybe she is an aspiring clown.


These are the faces which are not emitting for whatever strange reason.


This is the entire left-scalp vertex group selected.


Oh and the same exact thing happens on the right side of the scalp too.

Are all normals are pointing in the same direction. How does it show up in wireframe mode? How is it, if you hit “z”? Perhaps the normals of this faces are pointing towards the inner side of your mesh and the particles are emitted in that direction?

That’s it! I didn’t even know faces could face tho wrong direction. After you posted this I did some reading about normals, hit the recalculate button, and everything is better now. Thank you so much.

I’m glad I could help.