Why do normal BGE games not work properly in UPBGE?

(Brvdbury) #1

I’ve been using the normal 2.79 BGE for one of my biggest projects for a while now. I started working on it long before I knew about UPBGE and I now know it holds a lot more capabilities than the standard BGE.

I’ve wanted to bring my game over to UPBGE but I have noticed that there are many issues to do with animations. Why does this happen? What would I need to do to fix this?

0 Likes

(BluePrintRandom) #2

I am not 100% sure if things were fixed in upbge (correct behavior) or broken.

can you post a video of what is happening in upbge vs bge?

your logic?

0 Likes

(Brvdbury) #3

There’s a lot of logic bricks so it would be easier to summarize the issues I’ve found.

BGE:
Animations on armatures blend between each other correctly. Works like an armature should.
I am able to change the colour of the sky using World options.

UPBGE:
Animations on the armature still work but no longer blend between each other, they just freeze at their last frame.
I can’t animate the sky colour anymore. I completely re-did the animation for it and it still doesn’t work at all.

I read up somewhere that changing the layer to 1 on the animation actuator fixes the bug, but that does nothing. I must have read that wrong, not sure.

0 Likes

(Lyeb) #4

With python, you can use scene.world.horizonColor (or zenithColor) to change sky tone. It’s bit of a bummer because it’d obviously be simpler to just keyframe it rather than having to math your way into a color transition via code, but oh well.

Armature animations not blending into one another, on the other hand, should not happen; I don’t think I’ve had this issue. What’s your setup like?

0 Likes

(- Click for resources) #5

This is indeed true, i have/had the same problem, needed to redo all my animations.

0 Likes

(BluePrintRandom) #6

in upbge - I think there is some sort of checkbox somewhere, ‘static sky uniform’ or something.

still digging.

edit - “constant values”


bottom right corner.

0 Likes

(Brvdbury) #7

I have that option unchecked already. Tried checked and unchecked and it still doesn’t work (world animation).

0 Likes