Why do textures look wierd?

Hi All, If I stick a picture eg. jpg, tga file onto a face in the game engine, then all the gradients get distorted, or exaggerated. Is there a way around this? I would stick a screenshot into this text if I could figure out how to do it!

I see there is a block above called “Img”. How do I use it? Thanx


just do this ![here put your URL](here put your URL)

whoops wrung answer :expressionless:


do you have an intel graphics card?
[I seem to ask everyone this, and most of the time they seem to, but also most of the time they are having trouble selecting bones or empties…]

okay, so like this?:

many graphics cards downsample the colors in a texture, so smooth graidients will end up with hard lines when seen

I can configure my current graphics card (ati radeon 9600SE) to do this, but older drivers did by default. also, some older cards (like the 7500) always do.

there is no workaround without modifying blender
[and the modification would probably be to send pallatized textures to the graphics card with the pallate, instead of sending the rgb/rbga version]

Thanx for the replies. This is the effect that I’m getting. My card is an Asus card AGP-3800M with Riva TNT2 chipset. I thought that maybe this is a bug in Blender. I actually need to get another PC soon. Which graphics card is more compatible with Blender?


yeah, I’d really suggest a new card

my geforce 2 [mx 400, pci] runs blender quite well, but it probably can’t handle as many polys as my current card [ati radeon 9600se]

in general a nvidia geforce (2 or newer) card is a good bet

please consider that a geforce 4 Mx is essentially a geforce 2

geforce 2 cards cost about $40 (somehow…, they are coming on 5 years old)

the problem with ati cards is just that they do not support opengl as well, also, versions 2.25 (perhaps 2.24) to 2.33 experience an annoying slowdown in interactivity [delays increase after releasing mouse buttons with use, you have to restart blender to get the delay down to a managable amount]. Also, in linux installing ati’s drivers is somwehat more difficult [I personaly have never had success]

Thanx once again guy’s. I’ll just plug on, and see how it looks when I upgrade my PC.


ok first of all, sorry for bringing up this theard.
I too am also having this problem, what i would like to know is if i sent the blend file to my mate, then he makes the game an exe then sends it back to me, would this still give me this horrible effect?


it is your graphics card, you will always have this problem [until it is replaced in some form]

if you make the exe and send it to someone else, they may or may not have the problem [depending on their graphics card]

but you said it is a problem with blender so if i run it using an exe it has nothing to do with blender.
becouse when play a professional game the games work on most graphic cards without this effect



I’ll try to explain more then

the problem is that the graphics card or driver is changing the color depth of your texture. This is partly blender’s fault [blender gives the graphics card a 24 or 32 bit texture], and partly your graphics card [or drivers] fault [it does a real bad job converting to a lower color depth].

the games you speak of are probably sending a 8 or 16 bit texture to the graphics card [driver], which it can handle just fine, and doesn’t change [so it looks correct]

so, the problem is both that your graphics card [and drivers] aren’t good enough, and that blender isn’t doing anything to compensate.

[I should probably read my previous posts before responding like that]

also of note is that some graphic cards can be configured to do this, for example my radeon 9600SE with older drivers will do it when you setup the texture quality very low. [I haven’t tried with newer drivers]

i have a Radeon 9200 and the textures are distorted can you set it to not distort the textures? or do i need a diffrent card

32 bit color
highest quality textures [in advanced options]
newest drivers [4.11]

a geforce 2 can do 32 bit textures, a radeon 9200 ought to be able to as well [but not having one I’m not sure]

32 bit color
highest quality textures [in advanced options]
newest drivers [4.11]

a geforce 2 can do 32 bit textures, a radeon 9200 ought to be able to as well [but not having one I’m not sure][/quote]

That should be no question at all, every single video card since the times of ATI Rage 128 GL, Riva TNT (original) and Voodoo 4 (1997 to be exact) have supported 32-bit textures.

i just remembered i posted a here and i tryed all you said but the textures still look bad anybody have a 9200 and not have distorted textures?

oh yeah how do you set it to distort the texture?
mabye i can change it to not distort it there

I posted the original message, and I have since bought a new PC with a GE-Force 5700 card, and WOW, what a difference! I still have the older PC with the Riva TNT card (Asus), but I did not manage to get the textures to work well. All of the older GE-Force cards work well.

so i need a new card what would you reccomend?
and i play games also

Absolutely. Video has everything to do with it. We are using blender for business realtime purposes and so we run everything on intel chipsets with hardly any ram and on low end laptops. We have to because most buisinesses are not equip with fancy video cards. We wind up compensating for alot of nonsense, but its what makes it work for us. I would always think twice before blaming blender for video problems. It does so well on the low end! :smiley:

As stated before: GET AT LEAST GEFORCE NVIDIA! LOTS -O- BUILT IN RAM, AGP. It will speed every 3d game you ever played up! Ram and video. Its like the heart of lungs of gaming.