Why does a 'Compositiing' progress bar sometimes come up?

Hello,

Sometimes when simply tapping through frame sin my 3d viewport, it is slowed down by a ‘Compositing’ progress bar that comes up at the top of the screen for ever time i tap forward 1 frame. Can anyone tell me what this is about and how to stop it? Thanks.

As the message indicates, have you any node setup in the compositor that is updating as you change the frame?
If so have you enabled the ‘Auto Render’ option on the compositor header ? You acen turn this off or in the render / Post Processing settings turn off Compositing

No demo blend file supplied so cannot check for you.

That makes total sense, thanks.