Why does Blender add a lot of noise to my tracked footage?


I’m trying to track some footage of mine. I matched the camera settings, I made successful tracks and the video looks clear and fantastic in the Movie Clip Editor. However, when I try to Render the Animation, there is a lot of noise added to the clip. I am rendering at the highest settings in full HD, even matching output files with 20,000 Samples. But I can’t seem to lose the noise.

Is there a disconnect between the Movie Clip Editor and the Renderer?
Here’s a picture to show what’s happening.

I’ve tried changing my output settings and it doesn’t change it. I’ve tried rendering as AVI RAW, PNG, H.264, but no luck. I’ve tried changing samples, no change. Changed render engines (from Cycles to Blender Render), no change. I’ve tried changing exposure settings, track settings, nada. I feel like I’m missing something.

My specs:
Blender 2.74
OS: Windows 7 64 Bit

Output Settings:
File Format: H.264 (Though I have tried AVI RAW and PNG as well)
Channels: RGB

Rendered: 100 Would Be Ideal since it’s not very complex, but I used variations from 1-20,000

Any help is appreciated.

is there something that is rendered in above ?, of so be informed that dark scenes in cycles are always a bit problematic.
i wonder what your compositor view panel looks like, do you add some brightening there ?.
And what if you simply make it a bit darker afterwards, to get rid of the noise, in some cases if you set video compression to higher small noise gets removed (they dont cotain info) and thus zipping/compressing them more strongly can remove them in compressor unless you use a loosless codec.

if it is some result of a render job, you could make something in compositor that would turn anyting below a certain valeu to real black
or give it a try with transparant png’s. (i often render to png instead of straight to avi, since then if the process hangs for some reason you could just start rendering a new movie from the frame where it halted) adding an image strip, will then be your final png > to avi render.

But you can also check then if hose png’s contain your noise, before you mix it with your other video overlay.

I believe there may have been a slight misunderstanding. The image above is not one image. The image above is two images stitched together. I did that to show the differences on the same image. The image on the top left, is what it should look like. That is how I imported it into blender. The image on the bottom right, is what came out of the render engine. I didn’t even touch compositor yet because I handle my projects in steps. This way if something goes wrong, it can be troubleshot easier. Here are the steps I did to reproduce the image.

1.) Open a new blender file
2.) Delete the default cube
3.) Select the main camera, and set its location to:
X: 0
Y: -10
Z: 2

Rotation to:
X: 90
Y: 0
Z: 0

I do this so that I don’t get bizarre camera angles when tracking. This is also the same angle we set up with our mechanical jib which we had hooked up to a computer to determine the angles.

4.) Modify my blender frame rate to the exact FPS of the clip (23.98)
4.) Select “Movie Clip Editor” Panel.
5.) Click Open.
6.) Choose Video File, Click “Open Clip”
7.) Press “Alt+A” to cache frames (Still looking crystal clear)
8.) Input all of the camera settings (Or alternatively, do nothing with the camera)
9.) Select Tripod
10.) Place markers on the footage
11.) Solve the footage
12.) Select “Set as background”
13.) Select “Setup Tracking Scene”
14.) Press F12.

The scene is highly blown out and adds so much static, even on bright clips. Haven’t even touched compositor yet because the issue didn’t start there. I can use a screen captured video to show you what I mean if it helps even more. The movie clip editor still shows a crisp clip. But the renderer creates the noise. I appreciate you taking the time out of your day to try to help though

I ended up just rendering the models on a black background entirely. Threw the clip into Adobe Premiere and overlayed it on my original video.

UPDATE 7/27/2015 7:14AM: In the compositor, I found that if I detach any of the nodes (Doesn’t matter which one). Then re-attach it to the same node, the footage is cleaned up. For example:
A is connected to B by default. Disconnect A from B. Re-Connect A to B. No more blown out footage or noise. The footage quality drops a little but the original issue is gone when that happens. Perhaps it’s a bug. Strange that it happens on different machines and different versions of Blender