Why does everything look shadeless??

I have made a bedroom scene and rendered it in Blender. When i render it (enabling both Ambient Occlusion and Environment), everything looks very shadeless. No evidence of any 3D. Here is my file: http://www.4shared.com/file/nWjLM2qG/Bed2_1_.html . :spin:. Dunno why this happens?

enabling both Ambient Occlusion and Environment
Theres your problem. Look up stuff about some lighting setups. Lighting is a HUGE part of a rendered scene.

p.s. I can’t see your picture from that link. Just attach it to your post.

@smaller-tree
My advice to you is that this type of scene you do in real world measurements, because in this case, your bed is about thirty meters in width and length (if you choose a meter instead of blender units), which leads to some problems within ‘gather’ settings. If in that case your parameters are 10m for ‘distance’ and falloff set to 2, than you get shadeless render, if you increase distance and reduce or turn off ‘falloff’, shadow begins to appear. I hope this helps!