why does it stop snowing at 250 frames?

I have an animation running, with particles emmiting from 27 to 500. The render settings have the animation ending at 600. However, all velocity is lost from the particles after frame 250. I tried freeing cache (under particles>>bake>>free cache) and alt + a, but to no avail. Whats goin on? :frowning:

Problem Solved:
Blender wanted my bake in particles to be long enough. Setting at 250 doesn’t stop the emmition of particles, just the movement of them. Weird, but i’m happy :smiley:

In the particles tab, you have to raise the “End” number to 500. by default it’s set to 250 regardless of how long the render is. Hope that helps.