Why does my Blender crash when rendering.

Hi all!

When I am going to render my project, my Blender keeps crashing.
If I can’t render out then it’s kind of pointless.
I tried the render branch and new build of 2.5.

In my console it is written

Error, region type missing in - name: “Node”, id:16 (it repeats this about 24 times)
read blend. D:\projekts\armor\armor 14.blend
write exr tmp file, 360x640, C: mp\armo 14.blend_scene 1.exr
Mapalloc return null, fallback to regular malloc: len=4190208 in imb_addrectImBuf, total 1048340252
Calloc return null: len=4190208 in imb_addrectImBuf, total 1388392960

Any help is appreciated.

//Niklas

Check your RAM usage, try rendering a smaller image. I think malloc and calloc indicate your machine doesn’t have enough free RAM for the render.

Do you have OpenExr libs installed?

Thanks for the quik answer.

You were probably right, I maxed out both CPU and RAM.

Anybody know a way around this, like rendering different passes then combining in Node editor.
If possible I would like to NOT have to stitch thing together manually for every render.
I know I will need to render a couple of times to get the lightning and textures right.

What OS are you on?
Sometimes I run out of system resources on WinXP 32bit.
When that happens, I switch over to Ubuntu Linux 64bit and it can usually render the large scene.

I am using Vista 32.

I think I need to invest in more RAM, If I understand things right a 32bit system can use up to 4gigs of ram. I only have 2gig in the computer right now.
And maybe while I am on it upgrade to window 7 64bit.