Why does my MD5 importer not show up on my import menu?

I’ve downloaded each of these two scripts to import MD5 files, one of which is linked from the main Blender.org scripts page, and I’ve put them into my scripts folder with all the others, and neither of them will show up on my import menu when I open Blender.


Where are they, why are they not showing up? I’ve seen posts scattered around with people successfully using these so why can’t I see them?

is it the “correct” scripts folder?

maybe try putting them in a “user” folder (and set a path to that in blender’s preferences)?

oh, and if these are for 2.4x and you’re tryimg them in 2.5 they won’t work.

I’m using 2.49, and I’m putting them in the correct folder, other scripts I put into the same folder yesterday are showing up fine.

bump bump.

any console messages?

No, because I can’t select it in the first place.

I meant when blender starts up…

have you tried running from text editor?

Hm… that is a problem… it’s giving me this message:

Compiled with Python version 2.6.2
‘import site’ failed; use -v for traceback
Checking for installed Python… No installed Python found.
Only built-in modules are available. Some scripts may not run.
Continuing happily.

I installed the latest Python on this computer last month and then after seeing this today I just went and downloaded and reinstalled and tried again and it’s still giving me the same thing. What’s that about?

Just a “FYI”, not all scripts actually run/show from the script folder. That’s not a problem as they can be run (I do this all the time) by loading them into a “Text View” and then using “Alt+R” to run them. Pretty simple really, certainly nothing to be so frantic about :wink:

You may need to set up the Python Path if you keep getting that “not found” message.

Oh also… although other people successfully use them you need to keep in mind they may be using older Blender version so there are compatibility issues to consider - as Michael W said, none of these old scripts work with 2.50 for instance. When all else fails drop back to the last Blender version the scripts are actually written for, that way you know it’s not Blender causing problems.

You will not be able to export with 3.0 as the export script is not converted yet.

“the latest python” might not be what you need… version 3.1?

the first line says your blender is “compiled with Python version 2.6.2” so that is what needs to be installed on your system… an older or newer version won’t cut it…

you should be able to have different versions installed without any problems though.

Okay, I’ve installed 2.6.2 version and now I’m no longer getting an error message at start-up, but the new script still isn’t showing up. I’m not trying to export at this point, though the export script is showing up on the menu, I’m just wanting to import for right now. Can somebody point me at a tutorial for opening the script through text-view? I’ve never done that. I tried turning on text view and just hitting Alt+R to see what that would do like Kat-II mentioned, it didn’t have any reaction.

This is all that’s showing up on the console at startup now:

Compiled with Python version 2.6.2
Checking for installed Python… got it!

split your screen… and switch one of the section to “Text Editor”. Click “Open New” (will be a double headed arrow to the left of “Screen 12”). Once loaded make sure the mouse is over that view and then Alt+P.

It worked! Thank you!