Why does the solidify modifier doubles my mesh?

Hi all

I noticed a strange behavior while using the solidify modifier. I did the following (to reproduce):

  1. Add a plane and subdivide it a few times
  2. Select a part of that plane (not all vertices) and create a duplication of the selection with Shift+D and Esc
  3. Assign the duplication to a vertex group to solidify it later
  4. Add a solidify modifier and assign it the vertex group created in step 3
  5. Tab into object mode and apply the solidify modifier

Now all vertices of my original plane from step 1 have been doubled. I do not understand why because the solidify modifier was only applied to a part of the mesh… Did I do something wrong?
I attached my test file that represents the step 4. When I apply the modifier in step 5, all vertices of the original plane have doubled.

solidify-test.blend (609.3 KB)

The vertex stuff in the solidify modifier is for setting the thickness not turning it off.

I use this all the time for doing ship hull stuff to make nice bevels :slight_smile:

Hi Blenderer

does that mean that only the vertices in the vertex group get the “thickness” and the ones outside the vertex group get solidified but with thickness zero? Which means they get “copied” in place?

Regards
stabio

Sort of… it’s a wee bit twisty the way it works…

So here in this example, I made a plane and subdivided it. Then I assigned some of the verts to a vertex group called variation (can be called anything) with a vertex strength of 1.

Then in the modifier I picked the vertex group and set the factor to 0.1, that means stuff with no weight in the vertex group will be 0.1 of the height of the solidify thickness.

It also works with weight paint (2nd pic) but I find this to haphazard so I always use manual vert selection and assign them to the variation group.

Cool thing is, the weight can be anything between 0 and 1 which will translate smoothly to height values between the solidify thickness and the factor adjustment.


Here’s an example of the technique in use…

Hi Blenderer

ok I think i got it. Thx, that helped a lot!
To solve my problem, which is only solidify a part of a mesh with even thickness, I found the solution in “Face Tools” --> “Solidify Faces”.
Thx again!

Regards stabio