Why does this happen when i bake my mesh?

when i bake my mesh for the textures, they get all messed up and stretched and sized up why?

UV unwrap your object. The texture is not mapped to its UVs. Attach your blend (including texture) for a answer if this doesn’t help.

The object is already unwrapped to bake the texture? In the picture, where the “orco” button is selected, you need to select “UV”…

http://www.megaupload.com/?d=M21BLSZN here is the blend file. im sure i packed it, but if i didnt just tell me and ill send the pics

The streaky texture is from your actual image, when you baked it, did you have any textures set to “orco” mapping? if so, change them to “uv” or cube; when baking, you can use everything (or at least most) of the things you can use when rendering… (AO, cube mapping, etc… You have to set it up like an image in render, then bake should work when the render works…
(it would seem “orco” doesn’t work when baking textures)

(ALT-C for the text to mesh, text objects no work in the engine of game)

i changed all the materials to uv on mapto and its still stretch.

If you want, post the original blend you baked form and I can sort it so much faster, but apart from that:

try a new material with new texture channels (with the same images, ofc) sometimes blender materials “break”… :confused:

how many layers? if there are more than one UV layer then you need to name the one the texture should map to.

what are the layers? have you actually unwrapped the meshes? if not then you need to unwrap them, try using cube projection to avoid the stretching, or better yet mark seams (CTRL-E when edges are selected, then unwrap with the “unwrap” option)

there are the options I can offer…

Why would you need to “bake” the it in BGE ?