Why doesn't my boolean modifier do anything?

I’ve been reading post after post about booleans and why they don’t work and honestly, everything I’ve tried seems to fail. I’ve tried manifolds. Deleting interior faces. Recalculating normals. I’m just confused now.


someone marked this as spam or advertising?

Without a picture of the boolean modifier or even better, the blend file, we can’t help you.

can I upload the file privately? It’s one I’ve purchased so I can’t really post it freely here.

What exactly are you trying to achieve? It looks like maybe a union?

[I have to post this as multiple replies because of my limit of links in a comment.]

Oops sorry, I’m trying to cut a hole in the yellow object using the circle object.

I can cut the hole in another object, but not that.

this is the project: https://i.redd.it/3rc2oh5nu8s71.jpg

I’ve managed to separate all the pieces https://i.imgur.com/erR57k9.png

I’m trying to reply with links but I’m getting flagged for spam for some reason.

Basically… trying to cut a hole in the yellow mesh with the black mesh.

Hopefully this doesn’t get marked as spam… here is a video of what happens https://www.youtube.com/watch?v=g54sdQ8iGe4

It seems that the mesh you want to cut has overlapping geometry, maybe that’s the source of the issue.

A friendly redditor gave me the answer fwiw. Fast Solver fixed my problem.