Why hairs not assign to group

I have created group to assign the hairs and in the vertex group i assign but still the hair particles not assign on the top parts. Its flowing below also. May i know the reason.

May i know the reason i want to hairs on the red faces only. Any suggestion or help whats going wrong with my mesh.

hairs_issue.zip (1.8 MB)

If you wan’t hairs on the red faces only, then you need to paint out all the green parts. In the options for weight painting, there is a setting which turns zero black. Turn that on, as it gives a much better idea as to whats going on.

Alternately, you can just go into the vertex group, select the faces you don’t want hairs to appear on, and click “Remove”.