Why is a NURBS circle not round?

Hi,
this probably is a really simple question.
To recreate the problem please follow these steps:

  1. With Blender open, create a default NURBS circle
  2. go to top view (NUM7)
  3. rotate it around the Z-axis (r;z;then move your cursor)

As you will see, it is not perfectly smooth.
Now 2 questions:

  1. Why is it not smooth?
  2. How can I make it perfectly round?

Thanks in advance,
tillonius3002

You cannot make it perfectly round, but you can increase the resolution under the object data settings in the properties tab.

Increasing the resolution doesn’t seem to help much.

I think it is lumpy because it is basically a square. Try subdividing it in Edit Mode a couple of times (3 or 4), then use SHIFT+ALT+S in Edit Mode to make the subdivided (square shaped) curve circular.

Thanks, this basically works, but I wanted to use it as some kind of door, which rotates. Thats why it has to be round. It now is, but if I turn off cyclic, the opening is smaller. It could convert it to a mesh, and then make it bigger with a boolean, but if I want it to stay a curve, how would I do that?

How does it work as a door? Can you use a curve circle ?

can you show a pic of what you mean here !

i did a test and added a nurb circle and a circle and it’s the samething
so don’t see what you eman when it is ot rounded !

salutations

Ok, back from vacances, I wanted it to be like it works now.
Thank you! :smiley: